Dual monitors Keynote and Zoom

I bought an additional monitor to connect to my 13" MBP so that I could more easily give presentations over Zoom. What I didn’t realize is when I go into presenter mode in Keynote (which I need for my online trainings over Zoom) Keynote takes over both monitors, one with the full screen view and the other with the presenter mode with the next slide and notes and clock. I don’t want this presenter screen. I want one screen to have my Keynote slide deck full screen, and I want the other screen to have the Zoom interface so I can see who I’m training and monitor the chat box and polling within Zoom. Is there a way to do this? I hope there is a setting either in Keynote or Displays that I’m missing.

I just got done teaching with this set up, using a MBP and iPad running Duet. Zoom keeps the chat window and participants window active if you share the full screen monitor. Are you sharing the Keynote app instead maybe?

I haven’t tried it with Duet or sidecar. I guess those might be options. I use my iPad for my notes. But maybe I could use my phone as the 2nd monitor? Is there no way to do this with the nice big screen I just bought for this purpose?

This is an old thread, but it’s talking about the same problem: https://discussions.apple.com/thread/5522746

I couldn’t work out how to do this, so I’m exporting slides out of keynote (as images or PDF) and using openlp to display slides ‘full screen’ on the second monitor. And then Zoom shares the external display.

My use case is live-stream church gatherings. OpenLP is built for churches to display song words, presentations, and images. It’s not the prettiest application out there, but it may solve your problem.

My workaround for this is to first share the keynote app, then start the slideshow which plays the deck on my external monitor with the presenter view on my MBP (you can switch displays with keyboard shortcut X), then I drag the chat, participant, and grid view windows from Zoom over the keynote slide deck on the external monitor. I got used to it pretty quickly.

BTW, If you play the slides before sharing your screen, the keynote app will not be an available option.

2 Likes

I don’t think using Duet should make a difference. Try sharing the second monitor before you hit play in Keynote.

I have the same setup and tried all I could to get Keynote to work as it was my go-to for presentations. I gave up and switched to PowerPoint (surprisingly the export worked perfectly and all my slides worked the same as in Keynote, the only difference is that PowerPoint’s “magic move” is much better than Keynote’s). It has a feature in slideshow setup that lets it open in a window that can then be shared on Zoom, and this can be maximized on the second monitor. Then you can have any application you want open on the other monitor. I have been pleasantly surprised with a lot of the new features in PowerPoint, as it’s been around 10 years since I last used it, and I’m really glad I switched now. ‘Design Ideas’ and online pictures in particular are fantastic, and the smart art has improved a lot. Now, I’d never switch back. I am still using Apple’s templates for my slides though!

Another advantage for me will be not having to take my Mac with me when I do presentations at work. I’ve reached the point where carrying a 16" is not good for my back and being able to use computers that are already set up for presentations will be much nicer, and of course this was not possible with Keynote.

Alternatively, iPad can be used but I found it drops screen sharing regularly if you do not use an ethernet adapter (but is rock solid stable with a USB-C to ethernet). However, I tend to use this as my whiteboard and switching apps during a presentation doesn’t look good so I’ve been using the second screen for slides and iPad for whiteboard.

Yes, it’s super annoying that Keynote does not have a “slideshow in window” mode. I’ve submitted it to Apple as an enhancement request and suggest that everyone who cares does that, too.
I think that what @evanfuchs wrote above is a good solution. I haven’t tried it yet because I only recently discovered that the “use dual monitors” option in Zoom is good and useful. In the past, that option seemed like more trouble than it was worth, but now it is stable and adds good functionality. I look forward to trying Evan’s suggestion.

1 Like

Ummm is this a setting in the Zoom at on the computer? I’ve never seen this. Zoom has so many preferences I could have missed it. Can you help me figure out where this is?

Yes, it’s super annoying that Keynote does not have a “slideshow in window” mode.

I sometimes convert Keynotes to PDF files with the “Print each stage of builds” option selected and they present the PDF using Preview. The downside is that you don’t get transitions (though, these don’t tend to translate very well over screen sharing anyway). and embedded audio/video content isn’t supported.

Thanks Tim. For a typical presentation that would be great. But embedded AV content is pretty critical to my work.

Has anyone tried this with two external monitors? That seems insane, but if it will do what I need I would consider it. My laptop as the primary screen and then two external monitors.

Did you try what I suggested? I’ve had no problem showing embedded video in Keynote presentations that way.

Hi Derrick. I have not tried Duet because I need to share to a 2nd monitor, not my iPad. My iPad is already in use for another purpose. So this option isn’t going to work for me, unfortunately. Thanks though!

It should work with any external monitor (I just installed Catalina and can confirm it works with Sidecar as well as Duet - I can try it on an HDMI TV to be sure but I don’t have a proper external monitor at home). Try these steps in sequence:

  1. start a Zoom meeting
  2. start Keynote but don’t hit play
  3. share your second display (“Desktop 2”)
  4. play your presentation

Zoom controls should now be overlaying your presenter setup, and you can undock the Participants and Chat.

1 Like

You’re welcome, @Doty. I can totally appreciate how the Preview/PDF option won’t work in some cases.

If you do need to use Keynote, the best option I know of is to do something along the lines of what @evanfuchs mentioned earlier.

I have a variation:

  1. Open the Zoom participant and chat windows as floating windows.
  2. Move them to Display 2 (my presenter display).
  3. Start the Keynote presentation.
  4. Turn on Screen Sharing for Desktop 1 in Zoom.

When I switch to Keynote, the chat and participant windows are still visible, floating above the presenter display. This gives me the benefit of having both the presenter display and the Zoom windows.

The fact that I’m sharing my Display 1 (not just the Keynote app) also means that I can easily switch to other apps, which in my case is critical as I do a lot of software demos/training.

On a side note, as you may already know, you’ll need to enable the “Allow Mission Control…” setting in Keynote > Preferences > Slideshow to be able to switch to/from the Keynote app while a presentation is running.

I hope this helps!

2 Likes

Thanks @dfay and @timstringer I will try both of these options when I can get to my 2nd monitor! @dfay just to be clear, are you using Duet or Sidecar? I just upgraded to Catalina and haven’t tried Sidecar yet. I also own Duet, but I thought that both of these options were just for using with an iPad. I appreciate the education!

Trying to follow this. Do you mean a second display, or Desktop 2 as in “spaces”? I am using a MBP with a secondary monitor and wondering how to shuffle things around to try your suggestion. Thanks!

I’ve got it working as described with both - in both cases I’m using an iPad as the external monitor, but I expect it would work with a hardwired conventional monitor as well.

I assume this refers to the way Zoom labels the second monitor as Desktop 2.