Errors in Chronosync backup to NAS

I’m trying to backup a folder from my iMac to an external USB harddrive and to my Synology NAS using Chronosync Express (Setapp). This is a daily backup. The automatic daily backup to the USB harddrive works fine. The backup to the Synology NAS fails every day. My iMac is connected to the network via ethernet. The error is “cannot locate target”. I can manually choose the correct folder on the NAS and then it works fine. But I think it loses the connection after a while, and won’t auto-reconnect. I’ve tried to set up a connection through “Manage connections”, where I have tried numerous different ways to connect (IP-address, afp, smb) and put in my NAS user name and password, but nothing works. I keep getting “Settings are invalid or the remote agent is unavailable”. The latter is not true, because I can access the NAS just fine outside of these settings. I’m thinking it may have to do with port numbers, but I can find any information on that. Can anyone point me in the right direction? Thanks!

1 Like

Your best bet may be to Open A Support Ticket with the developer.

I’ve seen this and this issue previously discussed in this forum. Do some searching on “Synology” and other key words. For my conclusions Reconnecting to Synology NAS After "sleep" seems impossible : Fixed. Other postings give other advice. i’m not sure there is a good answer. Something, I think, about Apple’s OS.


The “sleep” problem that was mentioned in the post above made me realise something. When my iMac goes to sleep and wakes up, it can still find the drives. But… the Synology has a power schedule running where it goes off every night at 11PM and turns on every morning at 8AM. It could be that that interrupts the mounting. I’ve disabled the power schedule so tomorrow at the scheduled time I should be able to see if my backups run or not.

1 Like