External monitor settings suddenly screwy

Hi everyone,

Last night, I decided to mirror my external display instead of extending it and today it’s all fuzzy despite being set back to extended. And it used to be bigger in the little display layout picture and now it’s kind of the same size.

I’ve restarted, plugged back in, etc. and nothing’s changing. I even reset PRAM. Ideas?

I would try a different cable and dongle/hub, if applicable. Even reseating the existing ones. Not sure what it could be on the software side.

Edit: oh I see you said you plugged back in. Did you try a different cable?

It’s a “special” LG cable that’s expensive to replace. This is the monitor if anyone knows an alternative (the Mac cable that charges my computer doesn’t work).

I’m not sure that’s the culprit since it was working fine before the mirroring and not after?

I get that. My Macs have had a complicated relationship with HDMI over the years. Occasionally, I’ve had to unplug-replug just because, but I’ve also had cables and dongles get flaky, so I thought it was worth a try to rule out low-hanging hardware even though the timing would be a coincidence.

And yikes, that is an expensive cable!

1 Like

Try playing with the scaled resolutions available for your LG monitor. One of them might be what you were previously using. Also try variations on turning off and disconnecting everything and then hooking up and starting up again as if starting from scratch, which often works with Apple gear.

And mirrored, of course, means same display on both monitors, so I might expect the monitor sizes in the Display Settings to have been similar.

Since the LG is the wrong size in Displays, I think you need to make macOS forget the display:

In the following, you could change the files’ extension .plist-old if you’d rather not delete them. You’ll need a password for the files in /Library/Preferences, and all of the files might not be present.

In /Library/Preferences
Delete com.apple.windowserver.plist
Delete com.apple.windowserver.displays.plist
In ~/Library/Preferences/ByHost/
Delete com.apple.windowserver.XXXXXXXX.plist
Delete com.apple.windowserver.displays.XXXXXXXXXX.plist

Everything should be back to the defaults, and you can set them up anew.

I just tried this procedure on my iMac Pro, and it reset the settings for my external monitor.

Hi John!

This is very helpful. I don’t have a ByHost folder or the *displays.plists.

I deleted the one file I had com.apple.windowserver.plist but it didn’t fix it. :thinking:

I just had the idea to plug it into my wife’s MBP and it’s blurry there, too, which supports @evanfuchs theory, and I’ve bitten the bullet and back-ordered the expensive cable. I’ll report back when it arrives.

I just can’t “like” this, but I’m glad you made some progress :slight_smile:

1 Like

Have you tried the monitor settings?
The website says there is a ‘monitor mode’.
Perhaps it switched to TV Mode (or Crappy Mode)?

I’ve played around quite extensively with “unsupported” resolutions on macOS. I think the easiest fix, and what you may need to do anyway, is a bit of plist editing to manually define the custom resolution you want. Have a look here:

I’ve used this method for all sorts of fixes, from enabling native resolution on my 43" LG displays when Mojave insisted on scaling them, to running 3440x1440@60Hz on 2008-2011 MacBook Pros.

*Off-topic fun fact I have to geek out about: “supported resolutions” on Apple’s help pages are meaningless. Even a 2008 MBP, so long as it’s a dedicated GPU model, can comfortably draw enough pixels for a 4K display, and its internal screen at the same time to boot. The real limiter is the bandwidth of the DisplayPort, which is 10.8 gigabits per second on older DP 1 to DP 1.1a MacBooks. There are some calculators online to easily estimate the bandwidth a particular resolution and refresh rate would need. If you’re below the DP limit, it works great. Just need the plist edits per my links above. (For example, ultra-wide 3440x1440@60Hz or 4K@30Hz on vintage MacBooks.) If you need even slightly more bandwidth than the port can provide, however, it won’t run at all. (For example, 4K@60Hz on vintage MacBooks, unfortunately.)

Or perhaps more convenient is SwitchResX.
But since it does the same thing on her wife’s computer, doesn’t sound like a resolution setting. That leaves the cable or the monitor.

Not necessarily. It would be extremely suspect for it to be a hardware issue when software started causing it. And there is an edge case where it could be software. It has to do with updates. Bear with me.

  • You have the monitor set up on your Mac, and it’s working fine, at the correct resolution.
  • Somewhere on your Mac, the preferences for this monitor are stored.
  • A software update takes place. This software update breaks the resolution settings for this monitor.
  • However, because you already had the monitor set up, your old preferences persist.
  • That is, until you change the resolution, and then can’t revert it, as the settings no longer work.
  • Meanwhile, your wife’s system does not have the grandfathered, working preferences.
  • You plug it into your wife’s machine, also on the broken update, and, of course, it does not work.

This actually happened to me with an OS update once.

I’m not sure the SwitchResX recommendation was in any way related to my comment above it, but FWIW, for defining custom resolutions, I’ve never been able to get SwitchResX to work for some reason. RDM and custom plists is what has worked for me.

Have you tried resetting the monitor to its factory settings? It’s possible that the internal configuration of the monitor is out of whack.

Update: The new cable arrived and didn’t fix the problem. :sob:

I found this report of the same issue. Unfortunately, the LG community link on that post 404’s. SwitchResX didn’t do the trick, but I’ll futz with @Gem’s recommendations and report back.

Edited to add that I also reset factory settings, which didn’t work either. Also, I’ve reset PRAM a few times, as was suggested in that post. Sometimes with the monitor attached, sometimes without it attached.

Sorry to hear that @beck.
Did you also reset the SMC?

I haven’t! I’ll try that next.

There’s also LG’s OnScreen Control software, that might help.


What version of macOS are you using? I had resolution issues like this for a long time last year, but an update sometime in the past 6 months seems to have fixed it. I suspect that in my case the Mac was simply not recognizing the supported resolutions for the displays in question on restart due to a software issue in macOS. The only way to get the displays to work was to repeatedly unplug and replug them in (while the computer was running) until the problem fixed itself. It usually took less than 10 tries.

@beck any updates on this?

Were you able to contact LG about it?