Files saved on Desktop do not show up

desktop
mojave
finder

#1

Hi,

since my last Mojave update I have a weird issue, that seems to be not only Mojave related but came up on prior releases as well:

I do have the (not favoured) habit of saving print screens on the desktop while working (and I do have a Hazel rule, that moves all print screens older than a day to a specific folder and from there to trash after four weeks :wink: ).
So when I make a print screen, I usually use it in another application. However, I make the print screen and if I am then looking at my desktop it does not show up, if I look at the desktop folder it does not show either.
After searching though the internet I found the (very impracticable) solution to change the Preferences of the Finder and then they appear. So when I make a print screen, I go into the Preferences, go to Advanced tab and then click on and off “Show all filename extensions” … then they appear. This is true for looking at the Desktop directly or looking at the Desktop folder.
Is that a bug or a feature which I do not understand? This “solution” was already recommended when this appeared in High Sierra, so it does not seem to be a new problem - but I have never seen it before.

Any ideas, comments, thoughts - perhaps it is only a little something via Terminal?

Thanks for your kind help!

Sven


#2

In Mojave the screenshot floats in the bottom right hand corner for a little while before it saves to the desktop. Is that not happening for you? I can drag and drop it from there to most applications (Mail, Pages, etc.) and avoid it ever being saved to my desktop.


#3

Thanks, yes, they do flow at the bottom - but usually I am doing several one after the other and then start working with them … e.g. transfer them also to the iPad via AirDrop, an option the floating windows does not give.
This seems to be a clear bug and it does not happen to all users - but it is a long time problem :frowning:


#4

It is not a bug – it is a setting. In Mojave, press shift-command-5 to make this menu appear

Screenshot%20of%20Safari%20(2-22-19%2C%205-13-34%20AM)

Click “Options” then turn off the “Show Floating Thumbnail” option. (You can also adjust the “Save To” option.) From that point forward, the floating box does not open when you take screen shots, they are saved immediately to the desktop or wherever you set “Save To”.

If you use these options to set the destination to “Clipboard”, you should be able to use universal clipboard (or an app like Copied or Gladys) to transfer screenshots to your iPad without fiddling with AirDrop.


#5

Thanks quorm, but … I have seen the menu and played around with it but unfortunately it does not resolve the problem: although I disable the floating thumbnail, it does not save the file to the desktop unless I fumble around with the preference settings back and forth.

But I like the idea of the universal clipboard and that works - but still sometimes I need the print screen on the desktop and that still seems to be a but, if you ask me :frowning:


#6

Sorry. User error perhaps – something we all do :frowning_face:


#7

Yes it does, though in this case, there seems to be no handling error on my side. See also here.