Google Meet doesn't work at all, even after reformatting the computer

We’re supposed to use Google Meet at work, but my team has been using Zoom since last year.
However, I have a big presentation coming up, and I have to use Google Meet. The problem is that I just can’t get the audio to work. I can’t hear anything, and they can’t hear me.
I’ve checked all the “troubleshooting” pages, and they all focus on the “allow Chrome/Firefox/Safari to use your microphone and camera”, but of course I’ve checked that!
Also, the video works fine.
I suspect there’s a video codec problem, but since I’ve reformatted the computer without fixing the problem I am completely out of ideas as to how to fix it.
Do I have to host the meeting through Parallels?

I do not know anything about Google Meet but I had issues with Microsoft Teams on the Mac. It did work, but I wanted to be able to add other audio sources to Teams and to switch between sources. I bit the bullet and bought Loopback (also for other purposes):

The app is amazing and it is not cheap, but it can be configured easily and you can build audio routes for anything going on on your Mac while seeing what happens when it happens. It might be worth trying out just for debugging purposes. It is the tool to go to for audio routing issues.

“Before purchase, the quality of audio passing through Loopback’s virtual devices will be degraded after 20 minutes.” But that should be sufficient for debugging.

If you can get Google Meet to work with Loopback, it should be a misconfiguration in your Google Meet instance. If you cannot get it to work with Loopback either, it might be a more fundamental problem with Google Meet.

After all, the issue should be to make sure that the correct input and output devices are being used and permitted. That can be confusing at times.

Somebody reported a similar issue back in January.

My office use Google Meet too, and often my voice (or their voice) won’t work. My checklist of troubleshoot/to fix this:

  1. check the Settings ⋮ for Google Meet on Audio tab, for testing try set Microphone to «MacBook Pro Microphone» and speaker to «System Default Speaker Device».
  2. if the sound still does not work, refresh the browser tab several times while checking the (1) point until the audio works

Elaborating the (1) point, in my case Google Meet often use ZoomAudioDevice / external monitor’s audio output channel instead of built-in expected microphone & speaker device.
Elaborating the (2) point, it’s just another “have you tried turning it off and on again?” situation

There is also MeetInOne which is a Google Meet-specific Mac app. I haven’t use Meet at all so I can’t say if it will help with the issue, but it seemed worth suggesting.

MeetInOne is also available in Setapp.

I use Google Meet for some non-work meetings that I attend. I did have problems using it through Safari but when I use Chrome or Brave it has worked without issue. I have not encountered any issues with the video not working, and I have not actively installed any additional codecs onto my Mac.

However, while I am writing this it did occur to me that one of the first things I install on any computer I use (Windows or Mac) is VLC. As VLC can play pretty much any video/audio file I am not sure if it adds extra codecs to the system when it is first run, or if they are all contained within the application package. It may have no impact on video played through the browser at all.

If you do not have VLC installed it might be worth adding it to your system to see of this does add any additional codecs. I have no idea if this will help fix the issue you are having but as VLC is free to download and install it might be worth a try.

Darran West

Could this be a case of Google subtly breaking compatibility for browsers that aren’t Chrome? They’ve done it in the past.

Well, pull me backwards out of the bird box as we say where I’m from! VLC worked!

1 Like