Help Accessing WD MyCloud Home External Drive That Is Offline

I have a Western Digital (WD) My Cloud Home ( which is a network attached external hard drive. The way the MyCloud Home devices work is that you create a UN/PW and that is used to access the files via their local web ( interface as well as via MacOS.

I was trying to access the files on it yesterday via MacOS Finder and the password would not take.

Via the MyCloud browser based interface, the drive is saying that it is ‘offline’ and as such, that seems to be the reason I can not access the files. I have the drive connected to power and hardwired connected to my Wifi router via Ethernet cable. I am hoping/praying that the files are still accessible and able to be removed from the drive.

The LED on the front of the casing is ‘pulsing’ White. The LED on the back near the Ethernet port is green/occasionally flashing green.

In the MacOS Finder interface, there are two “partitions” of the drive, the one that I named ‘sgclark’ which held my manually backed up files and another named ‘MyCloud-XXXXXX’ (where the X’s are the device’s serial number) and in this latter partition, it holds my TimeMachine backups.

My MacOS/MacMini is able to detect the drive and the drive’s MAC-Address via Terminal.

I can still see the TimeMachine back up files via MacOS Finder, so this is giving me hope that the integrity of the drive is still intact and the issue has to do with something that is preventing the drive from getting online.

Does anyone have any experience with this sort of stuff and may have some tips or tricks for me to utilize.

  • Is there a way via MacOS Terminal to access the drive and move the files to my Mac HD?
  • Is there a way to connect the drive via Ethernet or USB (it also has a USB port on the back) to access the files?
  • Are there any other ‘hacks’ or ‘technical’ methods to access the files?
    Right now, all I want is to be able to get to the files that are on the drive and hopefully move them off of this drive.

I’m still talking to Western Digital support however they have not been terribly helpful.

And after this, I’m going to go get a dual drive NAS and maybe subscribe to Backblaze! :slight_smile:

First, have you tried restarting your Mac?

If that doesn’t work, In Terminal, enter the command

ls /Volumes

If you see the volume you’re interested in you can continue to explore using ls.

I was looking at the manual and the pulsing white led on the front indicates a lot of conditions. Normal operation is for it to be solid white. The Ethernet port has two LEDs, the bottom is the link indicator which should be green or amber. The top is the activity indicator which shows traffic on the network.

To ask the obvious have you tried restarting all the devices?

I have restarted all devices. A few times. However, it does not hurt to do so again. :slight_smile:

Please ask the obvious. Willing to investigate all options! :slight_smile:

The WD folks told me that the ‘pulsing’ White LED in the front indicates, in this instance, that it has something to do with the IP address failing to establish itself or something along those lines, which is in turn preventing it from becoming online. The back LED’s are green solid and pulsing on/off, so there is traffic/data activity happening.

I have an eero Mesh Wifi 6 router that uses WiFi 6 so I’m wondering if that may have an impact on this situation. The eero enables me to temporarily revert the network’s settings back to try to let the device connect however that did not work when I tried that earlier today. Will try it again tomorrow.

I went to Terminal and typed in

Is /Volumes

and what came back was

-bash: Is: Command Not found

When I just typed in


it responded with:

-bash: /Volumes is a directory

I literally have no idea what I am doing within the Terminal interface. If you have ‘idiot (i.e. me :stuck_out_tongue: ) proof’ directions, feel free to share or point me to a web page that has a similarly easy to understand set of directions and I will try to give it a shot.

After I did the above, I disconnected the drive to let it reboot/reset. And I think I will then systematically reboot every device and see if that makes any difference and then try again with Terminal if needed.

Did you type ls (lower case L and s)?

Or Is (upper case I and s)?

Lower case L is the correct version.

Try this instead

/bin/ls -a /Volumes

Everything in that command must be lower case except the ‘V’. Make sure you type the slash character ‘/‘ and not the backslash character ‘\’.

When you go into the Eero app does the MyCloud show up in the list? If you select it, does it indicate any issues? Since WD says the flashing white light is an ip address issue I’m thinking you have something wonky going on with your network. In the various restarts did you restart the Eero gateway? How about your cable modem (or whatever you have).

I agree with you that something with the Wi-Fi network may be causing an issue.

When the hard drive is on, it does show up on the eero app/wifi network.

I have re-started the eeeo gateway and the full network and the Comcast modem with no luck yet.

Eero does let me revert the network to less advanced settings which I have tried, and I’m going to try that again tomorrow.

I turned the WD My cloud off to just let it reset. And I’ll try it again tomorrow

It’s been a while but wanted to post that I was eventually able to get this resolved.

The problem with the WD MyCloud was that the capability to log in to the drive failed. I believe it was a hardware issue but I’m not exactly sure to be honest. I took the drive to a local computer store (in NJ) and they were able to take the MyCloud apart, access the device directly by bypassing the log in piece and extract the data. The actual drive itself was not encrypted so the data was easily accessable.

I then bought a dual bay Synology NAS (DS223) and moved all the data from the bad drive there and am now using the NAS for this data as well as my Time Machine backups. I’m really impressed with the Synology machine and capabilities.