How to force WiFi login page?

I often use the subway WiFi in NYC, but before you can use it, you have to go to one of those login pages. It is a mystery to me how to get it to show up. I sit and stare waiting for it to pop up. Sometimes it takes 10 seconds, sometimes 2 minutes. Is there a way to force it to display when I want it to instead of playing this waiting game?

1 Like
1 Like

I’ve tried that and it doesn’t work.

I have the same thing sometime happen with Starbucks stores. Sometime I connect automatically, sometimes I have to manually go to

Settings > Wi-Fi

and then either select the specific open network, or, if you’ve connected previously (and ‘Ask To Join Networks’ is turned on) just wait. Always works for me, but only if I manually go into the Wi-Fi settings.

Google (which owns the LinkNYC free Wi-Fi network) gets this right, though. Once I am in proximity to it it connects automatically.

Sometimes, going to a particular web address in safari starts the login process. For example at my work, I type the main university homepage into Safari and the login page always appears. Otherwise, it’s just as you described.

1 Like

I’m surprised that captive.apple.com doesn’t work for you, I’ve had good success with this tip for a while. Perhaps the DNS server is not able to resolve that URL…

Next time, try entering 1.1.1.1 in Safari and see if that jump starts the process. This has worked for me in the past.

1 Like

http://captive.apple.com/hotspot-detect.htm

This brings me to the Authentication/Login page for wifi at Starbucks pretty fast.

1 Like

Every time you see that happening go to

http://neverssl.com

It should then immediately popup the connection screen.

1 Like

I’ve noticed I have this issue if I have custom DNS settings. Removing them seems to solve the problem for me.

Is it possible to have custom dns settings on an iPhone or iPad?

Absolutely. I customize all my devices.

1 Like

You can also use the 1.1.1.1 app to set up secure DNS quickly and easily:

Go to

https://1.1.1.1

To get the app for iOS or Android.

The drawback of using the 1.1.1.1 app is that it works like a VPN so can’t operate when a VPN is active. I’d love to use the app for the encrypted DNS capability all of the time but can’t when on an untrusted network because I use Encrypt.me there.

Actually, I use EncryptMe and 1.1.1.1 together all the time, and it works fine.

Quoting https://1.1.1.1/faq/

Is the 1.1.1.1 app a VPN?

No. A VPN app typically proxies all of your network traffic. The 1.1.1.1 app only overrides and secures your mobile phone’s DNS traffic.

It does show up as a VPN on iOS when active, but I can confirm that it does not interfere with EncryptMe.

This tip is a lifesaver for me, thank you! :grin:

For the problem mentioned REALLY
Neverssl.com

Listen to:

https://www.macgeekgab.com/rss/mgg_mp3.xml

I stand corrected about coexistence with Encrypt.me but I can confirm the 1.1.1.1 app cannot run simultaneously with Cisco AnyConnect VPN which my company uses.

The VPN profile for 1.1.1.1 and AnyConnect are in the same section on the VPN Settings in iOS whereas Encrypt.me is under Personal VPN.

It looks like one Personal VPN and one of the other VPN profiles can be active at the same time but two from the same section cannot.

Curious. I wonder if there’s a technical difference or just a “policy” one.

In any case, good to know that there are different kinds of VPN, which is something I was not aware of.

I can confirm @JoePreiser’s findings related to 2 VPN’s from the same “area” cannot be active at the same time. 1.1.1.1 and Synology’s VPN are in the same block, and enabling Synology will disable 1.1.1.1

I used to have this problem all the time. I found that typing the IP Address of the gateway usually triggered the login screen.

However once updated to Mojave it has never reoccurred. Touch wood.