I’ve had it with Auto-Correction - I think

I don’t know if this is just me but I’ve become increasingly frustrated with Auto-Correct. I actually think I end up with more typos than less. For example, I sent a message this morning that substituted what I wanted, “I woke up…” with “I worked up…”

I also find Auto-Capitalization frustrating when I use initials, e.g., when I type Wed. inevitably the next word is capitalized. I’m going to experiment with my settings as shown below.

I’m curious, does anyone else run into these frustrations?


I don’t use auto correct on iOS/iPad devices – it’s bungled too many messages. On the other hand, with Messages, “Predictive” is very useful in speeding up composition.

Agree. I decided to leave predictive active.

I can’t stand any of the auto-* features.

Despite having all of these shut off, my phone still insists on changing some words after I’ve written them. I can’t comprehend where it’s coming from, but I wish it would stop trying to help me. :cry:

1 Like

With help/friends like that who needs enemies! :slight_smile:

1 Like

I’m a really good speller so I turned it off. ;o) It was driving me bonkers, especially because I am back in forth with English and Spanish all day long. It congers up some interesting sentences.

But I never learned to type. Not one of my brighter ideas NOT to take typing.

At any rate, I turned it back on. I was making too many typos.

I used to be blown away by how accurate auto-correct was on my iPhone 3GS. Now I type “his friend is named Tim” and it changes to “his friend is naked Tim”.


Don’t blame it on the spell checker. You should always reread the text before you hit that Send button. You need to know:

  1. Does it say what I want?
  2. Do I really want to send it?

I don’t know how many times I have reread something and thought, “I forgot this” or “I don’t want to say that.”

It doesn’t take that long and it might save you some frustration (or embarrassment) later.


That’s a constant issue for a bilingual like me. We usually combine Filipino and English in our sentences. While you can add multiple languages on the keyboard, there’s no way to combine two. It’s either a default or another language. I can live with it on iOS but on the Mac its a constant problem that I have autocorrect disabled.

I started using the SwiftKey keyboard for its swipe-to-type feature (well before it was implemented natively), but the other handy thing is it can recognise two languages at once.

1 Like

cool going to try this one. I usually avoid 3rd party software keyboards because of performance. Has this been addressed as well?

I haven’t noticed any performance issues with SwiftKey.

That gave me a laugh with my morning coffee. :laughing: I can’t tell you how many times I’ve had to correct Auto-Correct to avoid sending something that, given my position, would have been scandalous and headline worthy! :slight_smile:

Indeed, in fact, I’ve developed the habit of composing most longer emails in Drafts and then I use text-to-speech as a proof reading practice. This helps to avoid the problem of having my mind “fill-in” what is not actually in print.

Ah. A kindred spirit. I’ll do most messages over 1-2 sentences in Drafts, first. Sometimes, if it’s relatively important, I’ll also leave it and go back to it with a fresh view. Amazing what will pop out when I do that.

1 Like

My devices handle the two languages (English and Spanish) I speak pretty well. What I do is go for complete sentence in one language. Say I want to include Spanish words- I’ll write the entire thing in Spanish. If in that Spanish language sentence I need to include English words, I just put the word itself in quotes.

All my devices can handle both keyboards. I just switch them back and forth because it is easier. But I don’t use Spanglish. It’s not a good habit although at times you definitely need a word in the second language, ergo the quotes.

On my Mac I don’t have the second keyboard in place. I was thinking there is not one for the second language but Apple is considerably smarter than that.

1 Like

If you leave smart punctuation off, do you just leave apostrophes in place of left/right quotes?

“Not sure what you mean?”

When smart punctuation is off, tapping the single quote symbol actually produces apostrophes (straight) instead of left/right single quotation marks (angular).

I can’t type the symbols here as MPU seems to auto convert apostrophes to quotes.

1 Like

One of the few things I setup on new mac/iphone/simulator is turn off autocorrection.

Other than English is my second language, autocorrected dictions feel less expressive