Is there way for Time Machine backups to only when I'm not using my laptop?

My bluetooth logitech mouse and keyboard get laggy when time machine runs. Sometimes I have to sit and wait for several minutes before I can effectively use them when a backup is running. Otherwise , when I move my mouse, it can take up to 30 seconds for the cursor to move.

When the time machine backup completes, my laptop is back to normal - lightning speed responsiveness.

2019 Macbook Pro 16" 32GB RAM, 2TB SSD, 2.4 GHz 8-Core Intel Core i9
OS: macOS 10.15.6
Keyb: Logitech MX Keyss
Mouse Logitech MX Master Mouse 2S

I did some research and found this TM scheduler utility, but I don’t know if it’s any good.

There is another app called Time Machine Editor that might also do the trick. It says it can schedule and also have backups run only when my machine is idle.

Has anyone here used either of these apps? or even a different app?

Please let me know below in the comments.

Update: I should have mentioned That my Macbook Pro has both wired and wireless network connections. I don’t know which connection TM uses.

I also should have noted that I am backup to a Time Machine network share hosted by my Synology server. I’m going to check the SMB version while it’s running using the smbutil statshares -a command.

I’ve used this forThe same reason and it worked just fine; it was ages ago though.
Since changing to wired networking I don’t get that issue anymore so I let TM run free.

1 Like

Have you tried using the Logitech adapter? I don’t experience any issues with lag with time machine running when using it.

This is unusual, I get no slowdown at all when TM is running, and use a similar spec MacBook. It sounds like an issue with the mouse and keyboard configuration. Have your tried with other mice or keyboards, or other ways to connect?

Yesterday I was even using a Windows 10 VM and it told me TM was running, and the mouse and keyboard were perfectly responsive (Magic Mouse/Keyboard).

I used TM scheduler for my server box and it worked fine.

Do we know where the BT receiver on the MBP? I use Logitech keyboard and mouse and I have both going to the usb receivers. I had a USB hub I used on my iMac and had both the receiver and TM drive off of the same hub. Same issue.

Through research I found that if the there is a high data transfer going on it can affect some wireless technologies. Moving my TM drive and USB hub to opposite sides of my iMacs USB row solved the problem

1 Like

I have used TMEditor and it does seem to work at setting things to run when idle. You can also set it to run during certain hours.

1 Like

Digging this up, as this might be the cause of the Logitech issues I’ve been having as well! This is on a Mac Mini (both the 2018 MM and M1 MM)

I’d been googling for others that might have the issues, but I’ve found that my beloved Logitech K350 will drop and lag at certain points during the day. It didn’t seem to be at any specific time, but would react poorly to keyboard input. I didn’t have issues with the mouse, but that’s connected via Bluetooth. Before posting here asking for advice, I found this thread which could be the same issue I’m running in to!

I hadn’t considered that it might be Time Machine related (I’d narrowed it down to Mac related, as never had issues on Windows) and have instead ordered a Keychron keyboard. Depending on how my wrists get on with a standard keyboard (a cheap wired Dell had sufficed for a period without causing wrist issues), I might well try this again and see if it corresponds to Time Machine kicking in (and if it applies now I’ve a different time machine drive).

If it is Time Machine related its due to the data transfer causing interference. If its possible try and move the USB that are plugged in as far away as possible.

At the minute its not an issue as I’ve switched to the Keychron keyboard, which is Bluetooth and I’m not getting wrist issues.

Even harder to move the items apart on the M1 Mac, as there’s less ports!