MacBook Supposedly Out of Disk Space - Purgeable Files

After spending six hours on this problem, I am turning to the experts here. Here’s the problem - when I try to copy a 12 mb file to my 128 Gb MacBook hard drive, I am told there is not enough space. Running the latest version of Catalina.

When I look at About This Mac, Storage, it says I have about 54 GB total in Applications, Books, Music, 11.38 GB System, 7.89 GB available, and 49.98 in “other”. So yes, 7.89 GB is not much space (well, not in today’s computing world).

Yes, I have made sure there are no time machine snapshots. Yes, I have searched for large files using Finder, and yes, I have “optimize my disk space” turned on. I do not have any iPhone or iPad backups in mobile sync. I have deleted about 25 GB of files to make space. That space immediately becomes part of “other.”

I am told my Mac will remove purgeable when space is needed, but it will not. I tried to reinstall, but I’m told there is not enough space.

Any suggestions? I don’t want to buy a $30 utility for a one time use. For the past 20 years I have gotten by with third party disk apps, and it bothers me that I might have to do that now.

Oh yes, also tried repair disk from disk utility.

If you use Time Machine, you may have snapshots taking up space.

Yes, it’s usually local Time Machine backups. However try the free Disk Inventory X to map out how and what is on your drive. Also try Onyx (also free) to delete caches.

I think they covered that one

For the usual “maintenance” stuff, Onyx does the job. Also start Disk Utility and use the “Repair” feature.

I would also recommend Onyx. :slight_smile: