MacOS 12.3.1 and CalDigit TS4 dock: Ethernet broken again

There have been postings here and elsewhere on the difficulties with wired Ethernet connections using CalDigit TB docks.

I have a CalDigit TS4 dock connected to a 14” MBPro M1 Max. I was running MacOS 12.2, and experiencing no issues at all. I was particularly happy after getting my new Studio Display, as my prior LG 34” 5K monitor would take a long time (think sometimes several minutes) to wake from sleep, while the Studio Display was waking up instantly, as was my second display, a 27” LG 4K. Part of my reason for buying the TS4 is that it is, as far as I can tell, the only dock that supports two 5K displays through a single TB cable. I have a second Studio Display on order although I may cancel and stick with the 4K.

In any case, up to now my Ethernet connection has been working just fine. Last night I upgraded to MacOS 12.3.1. After reboot, I find that the Ethernet will connect for a few seconds, and then lose the connection. I tried rebooting, disconnecting and reconnecting the TB cable and the Ethernet cable, power cycling the TS4, with no luck. WiFi, if I just disconnect Ethernet, works fine.

This is frustrating that either CalDigit or ?Apple don’t have this right. I am suspecting CalDigit from what I have read online (there have been reports of issues with intel Macs as well, so I don’t know that it is due to Apple silicon.

I can use a USB-C to Ethernet adapter as a workaround, but still very very frustrating.

1 Like

Can you try connecting the ethernet cable to the Studio Display? Doesn’t it have some of the properties of a Thunderbolt dock, too?

Comparable issue with a Belkin TB dock and a 2017 MBP on 11.6.5. Ethernet just doesn’t work. Not al all.

I went for an el cheapo USB-C ethernet dongle which works just fine.

So far for the single cable to my MBP. :frowning:

@karlnyhus The Studio Display has 1 upstream TB3/4 port and 3 downstream USB-C ports. I can connect a USB-C to Ethernet adapter, but that isn’t an advantage over connecting said adapter directly to the TS4. The Studio Display is connected to the the TS4, which is the point so I can connect a second display to the TS4 as well and connect one (TB4) cable to the MBPro.

@vco1 Interesting that you are seeing the same issue with a different dock vendor, an Intel Mac, and a prior version of MacOS. I don’t have enough info to know if the issue is with Mac hardware (intel or AS based); MacOS; or the docks.

What bugs me the most is that it worked fine until I upgraded from 12.2 to 12.3.1.

You might try items “C” and/or “D” from the following Caldigit knowledge base article:

https://www.caldigit.com/my-ethernet-port-on-the-thunderbolt-station-works-intermittently/

edited to add: Or call Caldigit support - my experience was positive.

A Caldigit support rep talked me through the steps in “C” when resolving an issue with my Caldigit TS3+. This resolved the ethernet problem completely.

@Arthur Thanks for the suggestion. I had found that web page.

Interestingly, tonight I cannot verify that the port on my TS4 is actually working. Connected to my switch, I have no lights on to show that there is an active connection. I have tried three different ethernet cables, and also checked each cable with a connection to a different device (which causes the lights on the switch to turn on) suggesting that there is a problem with my TS4 dock hardware. If that is the case, then certainly an odd coincidence that it failed just when I did an OS update, but if so a better explanation for the problem I am seeing.

I am going to check the CalDigit website to see if there is email support. Otherwise I will try to reach them tomorrow.

With all respect, this article is the usual support BS. Recreating connections, checking cables, updating firmware (there is non for ‘recent’ models), doing a raindance.

The ethernet connection on my Belkin TB Dock has been flaky from the beginning… But stopped completely after a certain update of macOS (can’t remember which, because I already went for the el-cheapo USB-C dongle by then).

Unlike the Windows world, Apple has great control over the hardware that’s used in and with their computers. Still they don’t care to fix these issues.

Monitors are another problem b.t.w.

This is one of the reasons my next computer won’t be a laptop anymore. At least not the computer that I use at home. Although TB promised a “one cable connection”, this just doesn’t work in practice. So I’d rather use a desktop.

I have found the Ethernet on my Caldigit TS3+ has also become almost unusable. Starting about a month ago it just randomly disconnects throughout the day. This thread may me go digging around the CalDigit site and I found the following support article. I’ll try it out and see what happens.

https://www.caldigit.com/ethernet-port-on-the-ts4-or-ts3-plus-does-not-work-properly/

Edit: Welp. It died again after 10 minutes so that didn’t fix it.

Well, I tried reaching out to CalDigit. When you call their telephone support line, you get a recorded message basically telling you that no one is home, and instructing you to leave a message and they will call back.

I opted to send an email to support instead. I delineated the issue I have with the ethernet connection, noting that when I connect the TS4 via ethernet to my switch, I get no lights on either the switch or the TS4 to indicate there is a hardware connection. I noted this to be the case with three different ethernet cables connected to multiple ports on the switch and to multiple ports on a second switch, and that all three ethernet cables make a connection (lights lit both ends) when used to connect the two switches. In my mind, that points to the TS4 hardware.

I requested a warranty replacement and asked for a cross-ship as the TS4 is now central to my connectivity.

The email response directed me to the two support articles that have already been linked in this thread.

I replied that I did not think that was the issue given that the hardware is clearly not making a connection.

I have also tried removing the hardware profile as directed in network preferences and recreating it with energy efficient disabled, but that provided quite difficult to do as you cannot create the interface when there is no hardware connection. I was finally able to get it done, but nothing has been fixed.

Here is the next response:

“Thank you for the follow up. I’m afraid that without verifying that the Energy Efficient Ethernet settings on your computer have been disabled, we cannot be certain that a replacement TS4 dock would not see similar issues emerge. EEE settings are a potential culprit even with a full and proper connection to your switch. However, if you are able to confirm that this feature has been disabled, or that your TS4 encounters the same issues when connected to another Thunderbolt enabled host that does not have this feature, then I would be happy to proceed with an RMA under warranty given the following information:”

At this point, I’m not quite certain how I want to proceed. I suspect they are correct that another TS4 is unlikely to fix the problem, but I believe the reason is because of a hardware flaw in the TS4, not because mine specifically is defective. As such, I don’t plan to return it at this point, as I doubt a replacement will fix the issue.

For now I have hooked up a UBS-C to ethernet adapter and my wired ethernet works fine. I hated to “waste” a USB-C port but there it is.

As far as I am aware, there are no other docks available that can (or at least claim to) support dual 5K or greater resolution monitors. Right now I have an Apple Studio Display connected via TB and an LG 4K display connected via DisplayPort. I have a second ASD on order, with a ship date in June. If I decide to go ahead and add the second ASD, then I will need the TS4 to be able to maintain single-cable connectivity to my MBPro (assuming this actually works when I get the monitor), so at least for now I will stick with the TS4.

Disappointing. I have known of CalDigit as a high quality hardware vendor in the past, so I am disappointed that they seem to have a hardware issue and are not more proactive in acknowledging this.

@nlippman Hey Neal, I justed registered here to specifically respond to your posts, because I have the same issue and CalDigit gave me this answer.

So I’m quite sure another TS4 won’t fix the issue. Also the generic KB articles won’t fix the issue either. It seems Ethernet currently is broken/doesn’t work for TS4 and macOS 12.3.1. (Writing this weird so other people affected are able to find this post)

I can’t confirm on which side the issue lies, but I can confirm it’s very annoying :smile:. Since, as you, I currently just use my on-the-go USB-C Hub for Ethernet and it’s working fine I suppose at least it’s not a general issue, but more related to the combination TS4 and macOS 12.3+. I think CalDigit is for obvious reasons not willing to admit the extent of this problem. Since I asked the support to create a KB article adressing this 3 weeks ago, which hasn’t happened.

Not sure what to do next… not very happy with the way CalDigit is handling this – to say the least.

@awe: Thank you for bringing us this information. I appreciate your joining just to let me/us know; I hope you will enjoy our forum enough to stay!

It’s hard in these circumstances to know whether the problem is with Apple or the third party vendor. Having read many posts from others having the same problem, I was inclined to think it was a problem with the TS4. However, it is worth acknowledging that I did not have this problem in MacOS 12.2 and it started immediately on the upgrade to 12.3.1, so I can certainly believe it to be an Apple issue as well.

I do think CalDigit should do us a service and acknowledge this issue, even if to state that they believe it is an Apple issue and that they are powerless to fix it themselves. I realize they may lose some sales as a result, it perhaps the impact of unhappy buyers is greater. Certainly were not it not for the fact that this is the only dock claiming support for dual 5K displays I would have been checking my return options. Now that there is a stronger suggestion that rather than the hardware being flawed this may be an issue awaiting a (hopeful) MacOS software fix, I am far less inclined to do so.

@nlippman thanks for the welcoming words. I actually had a look around and found some interesting topics.

Regarding the update from 12.2 to 12.3.1: It was the same for me, so I also can imagine the problem is at least a mix of CalDigit messing up and Apple changing something that affected the driver in some way. So I also hope an upcoming update will fix this, since CalDigit claimed they were in contact with Apple. Let’s hope for the best.

@nlippman something else Neal: If you need the webcam and speakers of your StudioDisplay don’t update to 12.4 and 15.5. After the update the webcam of the Studio Display and the speakers stopped working for me. Facepalm.

Update: The problem is–again–related to the TS4. If the Studio Display is attached directly, Webcam and Speakers work again.

Wonderful.

I don’t know how much of this is Apple vs CalDigit.

I do use both speakers and webcam. I don’t tend to do updates immediately. I may well wait a bit on this one.

Curious, and sorry to hear that.

I had an audio problem with one of my two Studio Displays. After updating to macOS 12.4 and Studio Display OS 15.5 the audio problem disappeared.

After posting my experience with the Studio Display audio problem in this forum, another user (@Evan ) suggested that a simple re-boot of the Studio Display (unplugging/replugging from power outlet) might resolve the issue. You might give that a try.

CalDigit EU support just answered me, I’m directly quoting:

We have spoken to our engineers about your below case and they believe the firmware update that is being worked on for the TS4 will fix this issue. They have high hopes that it will as, from their testing of the firmware update, a lot of issues have been solved with it.

They’ve asked if you can please be patient and update the firmware when it is available. It should be released, on our website, in the next 2 weeks (based on what our engineers have said).

I’ve already tried rebooting the Studio Display, but no luck. I mean I could just plug the Studio Display directly for now… I just got very frustrated that 5k+ of equipment lead to such a freaking shit-show. Dare I say – it feels very ‘Microsoft’. I feel a longing for my dear Classic Mac Pro and my 30" Cinema Display – which worked for 10+ years without major hickups. But I sound like an old man. And the MacBook Pro with the M1… yeah… well… it’s a nice piece of hardware as long as you don’t plug anything Thunderbolt in it.