MacOS Catalina is out!

Karabiner is working fine with me.


Good to hear, @TudorEynon. Karibiner has also been working well for me so far (though, I literally only use it to remap the Caps Lock key).


Guess what! That is all I use it for too! wonder how many users of the app only use it for that?


I imagine there are quite a few people with this one use case.

1 Like

I’m in the same boat. Recently found this guy’s setup which has made almost the entire keyboard remapped with karabiner

1 Like

Is anyone else finding Catalina horrendously slow to download?

I installed Catalina on my 2018 MacBook Pro. No major issues, 3 things worth reporting.

It hung at the Find My screen during setup. After 30 minutes I forced a shut down and rebooted. Came back up just fine.

My Logitech MX Master 2S mouse wouldn’t stay connected via its USB dongle. If I unplugged and replugged the dongle, I’d get a few seconds worth of mouse movement, then nothing. I connected via Bluetooth and it’s fine now.

My internal SSD now shows a yellow warning triangle with exclamation mark as its icon. It seems fine: I can still write to the places I’d expect. Disk Util shows two Macintosh HDs, one with above icon, the other with normal icon. Apparently the “warning” volume is the protected system volume and the other is the writable one. Displaying them in side by side finder windows, the only difference is the the protected volume has a folder called I can access my home folder via Users in either one.

This seems a bit odd and confusing, and I don’t remember seeing a similar setup when I played around with the beta on a spare machine at work this summer.

Just recently upgraded and this has to be one of the wonkiest upgrades that I can remember. Got the barrage of allow/deny which is normal and completely understand the intent, but I’m sure it’s going to be dialog shock for most regular users. It is interesting that the Apple apps seem to be preapproved for access. Some of the weird things I’ve noticed so far:

  1. It put a Relocated Items soft link on my Desktop for things that couldn’t be migrated. Looking through the folder you can’t really see much without sudoing because most of what’s in there is owned by system at least for me.
  2. Opened Music and had to login about four times, it then tried to sell me a subscription to Apple Music, which I already pay for, but it seems to be working.
  3. The git install that comes with Xcode is completely broken for me, going to try a reinstall of command line tools and hope for the best.

Didn’t get the hang for the Find My during the upgrade that people are reporting. Definitely might hold off for awhile. I imagine updates to Catalina are coming soon.

App Store seems to refuse to load as well now. Just a blank window. Was working for awhile. Might be restoring from backup tonight. :confused:

Second year in a row that I made the mistake of installing the beta at the late stages (Beta 9) - did it this year because my Mac is a secondary machine and wanting Reminders to sync. Unfortunately this is also the second year that I’m stuck on beta with no GM seed or shipping version available to download. So here I sit on Beta 10… hoping I can get off the beta train at 10.15.1 soon. Oh well… lesson learned…

With Catalina removing all 32-bit support, are people finding that they have more free disk space than with Mojave installed as there are fewer/smaller libraries? Or have the additions to the OS eaten up any savings?

1 Like

I’ve had no problems with Catalina except album artwork in Music seems to flicker sometimes. Won’t update my work laptop for a few weeks, though.

Just did a nuke and pave. Downloading / installing #catalina now :crossed_fingers:

1 Like

I’ll let everyone else work out all the issues until I get new hardware capable of running it. Waiting on a laptop without a butterfly keyboard.


Not for me…pulled right down

Just got stuck in a restart loop because of not enough free space. This is really bad. No way out. I cannot even choose to boot back to Mojave. I suggest others to stay away for a while. I will have to reinstall Mojave through internet recovery or time machine backup. Hopefully it is going to work. :confused:

1 Like

Installed on Mid 2012 MacBook Air. It took long but installed and everything working fine.
I do think I significantly misunderstood the new Photos app feature called Days.

I thought Days would show me all photos from a particular day, like Jun 6, my birthday. I thought I would be able to just look at all the photos from every year for June 6. I do not see, like before, any way to do that. It shows me Jun 6, 2019 and if I scroll back a year, Jun 6, 2018 and back another year for 15 years…you get what I mean?

Anyone else have this impression of how Days in Photos was supposed to work?

1 Like

I did the installation of Catalina last night. On a late 2013 21.5" iMac. I had to restart after the “Setting Up Your Mac” screen hung up. That was the most noticeable hiccup.

So far I have noticed less “beachballing” than I was expecting. Before the upgrade it was frustrating and frequent. So far it is favorable for me. I am about to work in Keynote and Pages. Will see how that goes. While doing the install I was pricing out a new 27" iMac.


Both work fine in Catalina for me.

Yup had the apple id shuffle too. Sidecar worked first time. the PITA at the moment for me is dictation. Cant get it to recognise new line or new paragraph.