Mojave, Safari version 13.0.5 and Safari extensions

Hi all.
Finally upgraded to Mojave and Safari version 13.0.5 (15608.5.11) and have found that the Safari extensions preference panel does not permit you to check or uncheck permissions on any of the extensions you have installed. This is a pain for 1Blocker (I have a subscription) because after updating the app only the 1Blocker button extension was checked. I unchecked it and tried to check it again and it hasn’t worked again. Same on my iMac and Macbook Air. Tried restarting both macs and nothing. Any of you experiencing the same issues? What do you recommend? Thanks.

Have you asked 1Blocker for help? Most likely a request for permission popped up and was not noticed. That is not uncommon.

Yes. Waiting on an answer. The strange thing is that I cannot check or uncheck extensions from other developers: if it was on it stays on and vice versa. Strange.

Does this help?

Thanks for the suggestion, but no. Toggled on and off to no avail. 1Blocker support suggested unintalling the app, restarting and reinstalling, but didn´t help either. Curious is the fact that all extensions (not just 1Blocker) are frozen in the state they were pre-update to Catalina.

I find if remarkable that we’re at this point in the software where people are avoiding an upgrade. I haven’t seen this since they removed classic.

Thought I would pass along this thread.

1 Like

@Leimam . Restart in safe mode. Restart then hold down Shift until it turns on. Check if you like in case I got that wrong. Safe Restart is what you need.

Go to Safari extensions panel and they should take the tick.Then restart normally and leave then alone.