MPU Discourse Images

Recently I have noticed that most images seem to be displaying as just a blank box for me on this forum. If I tap on the image box it displays a message that the image could not be loaded. This happened for a few days and then seemed to fix itself, but is now happening again.

I am a member of a few forums (including Automators and Drafts for example) and there is no issue on the other forums.

I can’t even see images that I have uploaded. It is happening for historic and new posts.

Links are displaying correctly.

I have tried logging out and back in to the forum, as well as deleting Discourse, rebooting and downloading it again. This is happening on both my iPhone 11 Pro Max and iPad Pro 12.9 2018, both running the latest public (non-beta) release of i*OS. It also happens if I try logging in directly from Safari.

Anyone any suggestions? Thanks.

If you’re using any content blockers try turning them off (or whitelisting this site)

1 Like

I’ve had no issues, can you link to a post where this happens for you?

The MPU forum images are hosted on separate storage, it’s possible that this is leading an adblocking or privacy plugin to block them.

1 Like

@bowline Thanks for the suggestion; using 1blocker. I have just whitelisted the site, logged out and logged back in, no difference unfortunately (safari or app). I’ve also tried turning off the blocker completely to no avail.


One of my own replies that I can’t see the image in…

and another random one that is not my post or image…

Thanks for looking into this.

The images in both the posts you linked to show up just fine. Try to reload without content blockers, or quit the site, and clear cookies.


1 Like

Thanks @KVZ for the confirmation they do load correctly. I’ve also tried without content blockers and have also cleared the cache and rebooted, thanks for the suggestion. Still doing the same…



I’ve narrowed it down a bit – but no less confused!

All the images seem to load if I turn off my WiFi connection and use my mobile data connection instead. Nothing has changed on my home network, unless something has changed on the provider side. Still doesn’t explain why it’s only happening on this forum.

More playing tomorrow to see if I can narrow anything else down.

That happens to me from time to time when connected to public WiFi. but I mage loading failure (or failure to load an entire site) usually occurs with any site I visit. I don’t know what the specific issue is but sometimes turning WiFi off then on again inside Settings fixes it.

NYC has a system of free WiFi throughout much of Manhattan (LinkNYC, owned by Google, I believe) and I have that issue reliably occur with one specific router near my local bank; I swap my connection from LinkNYC to the bank’s WiFi connection and images/sites load.

1 Like

That’s part of what is confusing me; it is only images, only on this forum and only recently, with no changes to my network (locally – who’s to say if anything changed provider side).

I’ve tried rebooting my home network and that has made no difference at all.

Thanks again.

Did you try clearing cookies and caches in your browser?


1 Like

Hi Katie, Thanks for the reply.

I have logged out of all the Discourse forums, deleted the Discourse app, closed all my other apps and then in Settings —> Safari I have turned off my content blocker completely and also tapped “Clear History and Website Data”. After this, I rebooted the phone and re-downloaded the Discourse app and logged back in just to the MPU forum. This is still producing the same issues – images only seem to be available if I am not logged in to my home wifi.

Is this what you were suggesting, or am I missing a step?

Thanks for your suggestions.


Yep, Tony, that was what I was suggesting.

Sorry it doesn’t work :frowning:

Also try going to Settings > Safari > Content Blockers and turn any CBs off that might be on.

If you access the site in Safari and “request desktop website” do you have the issue?


1 Like

Hi Katie,

Yep, all the content blockers are completely off.

Just tried that at your suggestion and, yes, still the same issue. The iPad Pro 12.9 2018 I believe also uses desktop mode in Safari as standard and I am getting the same issue there as well.

Thanks for your ongoing suggestions.

Last suggestion :mrs_claus:

Bounce your router.


1 Like

Unfortunately, I tried that one this morning as well. You’ll be surprised to hear that it made no difference either!

Thanks again for taking the time to put forward suggestions. They are much appreciated.


If it’s on both devices it might be your upstream provider. I’m using a VPN at home which on occasion hiccups with missing images on my Mac, and I just switch to a different node.

1 Like

It is!

I have a VPN on my phone, not my home network, and it is generally switched off (and has been throughout this issue). After your message, I have just tried turning it on and I get all the images now. Turning the VPN off again reverts to the images failing to load.

That’s the conclusion I’ve come to. It’s strange that it’s only on one forum, but the only constant throughout seems to be my provider.

Thanks for your help, it’s appreciated.


1 Like

It may be that the image host has ended up on a blacklist that your ISP uses (DNS or otherwise). One thing to try is to manually set your DNS server to something other than your ISP’s ( works well, provided by Google); it’s no guarantee, because your ISP could block or redirect it, but that’s rare.

1 Like

Thanks for the suggestion, I’ll have a look at that.