Running Shortcuts using Time of Day

Has anyone got this to work consistently yet? I get the following box and I have to run it manually:

Not sure if there’s something in my shortcut - I doubt it as I’ve made the device vibrate and send an alert as the very first thing.

The time of day part simply runs a shortcut

I’ve got an automation that grabs HomeKit data and writes it to a text file running happily by itself hourly.

There’s probably an action in the Shortcut that Apple wants a user interaction for; you could try stripping down the automation to find out.

Does the Homekit / text file writing happen from a Shortcut or directly in the automation?

I have this with an NFC tag - only since iOS 14.

What do you have @MartinPacker?

Not sure I understand the question but iPhone 10S MAX running iOS 14.0.1. (Happened on 14.0, too, if I remember correctly.)

Sorry just wondering what you do with an NFC tag and time of day automation.

It’s a Shortcut

Nothing. I’m just pointing out I get the same (unexpected) message when I tap on an NFC tag. I wonder if the two issues are related.

1 Like

Came here, because I was wondering about the same thing.

I have an NFC tag above my water kettle which I used to tap since iOS 12 (?)/when NFC triggers to Shortcuts were introduced to set different timers. Since iOS 14.0.1 (at least) it prompts me to first confirm that the Shortcut should be run. That wasn’t the case before and is a step backwards.

Can someone confirm that this also existed in iOS 14?

1 Like

water kettle

This is not exactly on topic, but now I’m curious about what other kinds of kettles there are…

Closer to on-topic: do you run a tea timer with that NFC tag? That is very clever!

@wolfie Interesting… I have many questions, but I’ll make Google answer them.

All: I just caught this tip on Reddit:

Anyone that’s on iOS 14.0.1 that have automations that aren’t going off, try deleting and rebuilding those automations

(there’s no other info in the link, but it has 6 upvotes. Haven’t tried it myself yet.)

1 Like

I’m on 14.0, and my time of day shortcuts are running fine. I still get an alert when they run, but I do not have to tap to continue. they are continuing to run without my interacting.

now I’m nervous to do the 0.1 update…

oooh! got it!! thanks :slight_smile:

I just created an automation to run a Shortcut to vibrate my device as a test and it worked.

I then changed the above Shortcut to vibrate the device, and then run another Shortcut to turn my torch on, and this also worked, so it seems rebuilding the Shortcut might work.

PS: turning a torch on as part of a time of day automation could be a pretty mean prank to play on someone!

I’m also finding the automations just don’t even run a lot of the time with no obvious issue. I don’t even get the notification that the shortcut is being run (it’s like the automation doesn’t even try to fire).

Same here. So frustrating.

Issue for me since updating to 14.0.1. This was all running fine in 14.0. For me, Automations stop working at exactly midnight and they will not start working again until I restart my phone. Issue occurring on my iPad also and it happens every night without fail. I updated my phone to iOS 14.2 public beta 2 and it has not changed.

I’ve posted about this on reddit and Automators, but I haven’t been able to find a fix yet.

Is there a way to turn off those notifications?

Can I just check that you haven’t found a way to run the same shortcut every half hour?

I found that when the scheduled shortcuts weren’t running, Backtap didn’t work either.