Scansnap S1300 error message


#1

Hi Everybody,

My Scansnap S1300, which worked perfectly for years, suddenly refused to do its service. I got a less than clear error message that states:
“The operating environment of the program is abnormal, confirm the correct installation of Scansnap”
(I translate from French this message which looks itself like a poor translation from the original English lol)

My system is Sierra 10.12.6.

Till today the program was working perfectly and it was already on Sierra.

What changed since last correct execution (which was last week)?
The only think I can notice is an update from OS X.

What I tried?
Try to upgrade the scansnap manager (but there was nothing to upgrade)
Uninstall and reinstall

No success.

Any clue would be welcome!

Regards


#2

I eventually tracked down the correct error message in English (mine was in French): Program’s operating environment is abnormal.

Research with this message havn’t helped much though and I’m still stucked with the Scansnap on Sierra.

Just to be sure there wasn’t any issue with the hardware or the cable, I tried the s1300 on an ubuntu machine and it worked seamlessly.

Still wondering if anybody got this issue on Sierra?


#3

I guess I’ll have to forget my Scansnap S1300 on Sierra 10.12.6… This morning, Fujitsu support answered my request in a very weird fashion.
They suggested to uninstall the current version of Scansnap manager (I told them in the description that it was what I did at first). Then, I was suggested to download the S1300i version and provided a link for this. Wondering if they realized that I was owning a S1300 instead but nonetheless, I tried it. Of course without success.
And, as a fallback, they suggested to reinstall the OS itself (even if it works seamlessly).

So… here were my options: buy a newer scansnap or another make, or install the scanner on another OS. Since 2011, I don’t use anymore Windows at home and don’t want to make a specific install just for this. Or install a Linux distro on a small factor or a VM.

I choose to install on a NUC I had from another project with Ubuntu 18.04. Scansnap S1300 was immediately recognized. With the gscan2pdf utility, I’m able to scan full duplex multipages pdf. But I miss a very useful feature that I had on my MacBook with the Scansnap software: scan to different formats and directly to Evernote or to Google Drive. I will have to find some hack to get that again. Maybe with IFTTT.

But such a shame that a perfectly working scanner is now obsolete on my MacBook!

dw


#4

Hi there, I’m nor sure I understand your problem fully. What version of Scansnap Manager are you using that is not working? I also have a Scansnap S1300 and am using Scansnap Manager version 6.3 L70 (even know the Fujitsu website doesn’t show this Scansnap Manager version compatible with Scansnap S1300). However, I am on MacOS Mojave (Version 10.14). The Scansnap Manager version 6.3 L70 is here: ScanSnap Manager V6.3L70 Update link

Also, are you able to upgrade from Sierra? Is that an option for you (rather than buying a new Scansnap)?


#5

I tried your solution but i encounter issues.

Let me explain: as the different tries I already did failed I uninstalled the software. The last version I uninstalled was that for S1300i not S1300 as suggested by Fujitsu (withouyt success).

So, I couldn’t use your link because this is an update and I get the message that there’s nothing to be updated. Nothing surprising here.

So I downloaded a complete Scansnap manager from the Fujitsu website for the S1300: http://www.fujitsu.com/global/support/products/computing/peripheral/scanners/scansnap/software/s1300m-setup.html

Then I try to apply the update you mentionned but this time the message says that it’s not the correct target for the update. Hum…

By the way I have a question: my version (the only one that can be used with S1300, according to Fujitsu is V3.2L80. How did you manage to use a 6.3 for Mojave. Is there another repository I havn’t found yet?


#6

Hi there. Even though Fujitsu says that the latest Scansnap Manager software version that works with S1300 is V3.2 L80, I have been able to use Scansnap Manager V6.3 L70 with no problems for my S1300 (I think other people in the MPU forums have found the same thing). I don’t think Fujitsu officially supports S1300 with the Scansnap Manager V6.3 L70, but (at least for now) it works for me.

You should read this webpage which shows you steps to download Scansnap Manager V6.3 L50 (under “Workaround”, install the dmg file for V6.3 L50. Second, install update V6.3 L61, then update for V6.3L70) and do a step-by-step update: ScanSnap Manager Incompatibility Information


#7

You may have tried to install an update, not a full software version. You actually need to install V6.3L50, then the updates to V6.3L61 and V6.3L70 in sequence.
In the link below, follow the instructions in the section labelled “Workaround”: http://www.fujitsu.com/global/support/products/computing/peripheral/scanners/scansnap/faq/hsierra004.html

Don’t try to navigate Fujitsu’s support website using your ScanSnap model number. The version V6.3L70 in the direct link above works with multiple models of the ScanSnap line of scanners, even though this version was officially designated for another scanner. Fujitsu is transitioning to its new software, “ScanSnap Home”. Several older scanners are no longer supported with this new software, effectively rendering certain scanner models obsolete. Welcome to the “Fujitsu Orphans Club”.

This Fujitsu ScanSnap problem has been discussed extensively in other threads in this forum. I posted a series of links to many of the forum threads in post # 37 of the thread in this link:
https://talk.macpowerusers.com/t/mac-power-users-464-stephen-who/10357/37

Good luck - Hope this helps!


#8

you’re right! I revised my reply to OP also to say the same thing - need to install V6.3 L50 first then do the step-by-step upgrade. Fujitsu makes it so difficult!


#9

Yes. Fujitsu has shown a stunning disregard for its customers.

The silver lining in this dark cloud is the presence of this excellent forum in which many informative posts have allowed us Fujitsu Orphans to share helpful information. The reason for all the posts here is the heavy Fujitsu advertising in the MPU podcast.

Please join us in asking David and Stephen to address this issue and call on Fujitsu to do the right thing.


#10

Thanks for your help to both of you! I installed the V6.3 L50 and the two updates in sequence but unfortunately, it didn’t solve the issue. I still have the error message “Program’s operating environment is abnormal”.

Just a reminder that may give you ideas for solutions: it worked for years and even with Sierra. Why I suspect my problem to be related to a 10.12.1 to 10.12.6 upgrade? It’s because it’s the only thing I did in the days before I discovered the issue when trying to use the scanner. But maybe it comes from another reason. But I have no clue and after all, the error mention an abnormal operating environment.

But I don’t want to give up because I realize that for other members of MPU the scanner works even with newer OS than Sierra and the scanner itself is not at fault because I can have it to work under another OS. So still looking around for a fix!

dw


#11

Here is a tidbit of information that may be a clue to a solution: It was the update to macOS Sierra version 10.12.2 in late 2016 that resulted in ScanSnap issues as well as Apple’s preview app issues. Apple re-wrote PDFKit, and maybe Preview as well. Fujitsu was slow (several weeks) to update its software, which uses PDFKit to function. It seems “convenient” that your problems appeared during your macOS upgrade past the 10.12.2 version. There is some interaction between macOS and ScanSnap Manager - there could be a problem related to the sequence of your macOS and ScanSnap Manager installations.

Another datapoint: My S1500M works well with this version under macOS High Sierra 10.13.6. Can you update to that version of macOS?

Try doing a search in this forum for “S1300” to see posts related to your specific model.

You could try other fixes (3 different suggestions, no particular order):

  1. Update to High Sierra 10.13.6, then install the ScanSnap Manager V6.3L70. - OR -
  2. Uninstall Fujitsu software. Empty the trash folder. Boot into Safe Mode - this clears caches and has helped with obscure problems. Re-install the latest macOS version your computer will support, then re-install ScanSnap Manager V6.3L70 (following the sequence from V6.3L50, then L61, then L70. - OR -
  3. Other users have reported that scanning software Vue Scan and Exact Scan have worked for some models of Fujitsu ScanSnap scanners.

Good luck, and keep us posted!


#12

Thanks Arthur,

I guess that an upgrade to High Sierra or Mojave is due for me anyway. What prevented me to do it is that I use many tools (most of them command line ones like pdftk server version and so on) or software (like GPG suite) that are sometimes touchy to manage after such an upgrade. In the past I struggled to get things working again. And the trouble makes me wary of upgrading.

But if anything else works, that’s the path I will certainly take.


#13

Before trying to upgrade to High Sierra or Mojave, I tried the proposed solution of using ScanSnap Manager V6.3L70 (after installing and upgrading in sequence from L50. No luck. Still the same issue as soon as the installation is finished: “Program’s operating environment is abnormal”.

But thinking again, I also noticed that two minor but very annoying issues appeared at the same time that the Scansnap problem. That is, just after upgrading to Sierra 10.12.6 from 10.12.1 or 2 (can’t remember).

Just to be clear, I don’t want to be off-topic with these two issues here, but just in case, it may give some clue about what happened to my Mac with this issue.

  1. now, after every restart of the computer, I have to change manually the way I scroll with the trackpad.
  2. I can’t disable alert sounds neither from the general settings nor each specific application notifications settings. It’s very annoying, especially in iTerm2 that now bells all the time, even on autocompletion in some situations.

I don’t know if it may help to solve the Scansnap issue but these three problems appeared alltogether after the Sierra upgrade. Hope it’s shed some light…

dw