Siri Search not working - cache issue? any fixes

Just to report back:

I went to the Apple Store where they confirmed there’s nothing physically wrong with my phone. They agreed that it was probably some sort of corruption/software issue, but that there was no fix-in-place options.

They had me to a clean install, and set up as a new phone (they said if you restore from backup, you might just import the corrupted index).

I’ve done that, and aside from the annoyance of setting up a new phone, all seems to be working well.


Thanks for the follow up. That’s exactly what happened with me, unfortunately, and it looks like what I’ll have to do again to my xsMax.

1 Like

I did a backup/restore and it seems to have fixed the spotlight search, but not the search within the Settings app. I am going to give it a day or two then decide how much I care.

1 Like

Hmm, maybe I’ll try that too. Today I was trying to change a setting and couldn’t figure out where it was in Settings and I ended up Googling for the location. (Turns out it didn’t exist, but was a setting in macOS.)

Missing search in Settings is annoying, but missing Siri search was a deal breaker for me. The prospect of backup/restore actually seemed less daunting than resetting settings, then hunting and pecking them back to place.

1 Like

Update: 24 hours later, Siri Search and Settings Search are fully operational. If you’re considering a nuke and pave or Settings reset, you might want to try backup/restore/wait first.


Wow. Okay, trying that tonight then.

Was your backup an old one or one made while you were still having problems?

I made a new one. I wasn’t sure when the problem started, but it was going on for at least a couple days. Plus I wanted to back up my watch. So I unpaired it and did an iCloud backup.

1 Like

Thanks… I didn’t want to do an iCloud restore because I have hundreds of iOS apps installed and restore takes forever. Restore from an encrypted iTunes backup takes less time. But if your restore was from a recent backup I’ll just try doing the same from iTunes.

I’m having the same issue in both my iPhone and iPad.

@evanfuchs just to be clear: you did an iCloud backup, wipe the device and then restored from the backup?

1 Like

Yes. I unpaired my watch to force a backup to the phone. Then I did an iCloud Backup. Wiped the phone, restored from backup when prompted. Repaired my watch. Then waited for everything to download.


UGH. I’m having the same issue on phone. Not looking forward to the re-install process… thanks all for the tips and paving this road already!

1 Like

FYI I decided to wait it out for an update. Applying today’s iOS update (finally!) seems to have fixed the issue on my XS Max.

1 Like

Thanks for the heads up @bowline. I can confirm that the most recent update fixed this issue on both my iPhone and iPad. I don’t see anything about it in the changelog, however. I just hope it stays working :crossed_fingers:

Sadly I’m still suffering from this, even after iOS 13.

Maybe 13.1 will help. Otherwise I’ll try the restore-from-backup route and report back.

Just to keep using this thread as my personal log on this problem, the reset-and-restore didn’t fix it. It worked for a little while, but then I started having search failures again in the same day.

However. It’s too early to say, but I think I’ve figured out what’s causing this. I think it’s a problem of performance and demands. I never have any issues on my 11" iPad Pro, while my iPhone XR is the thing that’s failing me. My wife’s XR never has trouble, though. So I did some thinking and looked through the apps feeding Siri’s search. Sure enough, there’s a few in there that have a lot of content; DEVONthink To Go and my mail apps, for instance. I’ve disabled their input into Siri Search results and it seems to be working better so far.

Fingers crossed!

1 Like

I’ve been having this problem again as well. Im going to try removing DEVONthink to see if that helps…

I’ve had better performance in general, but it still fails sometimes.

What device is this happening on for you?

Another observation: search also fails in Settings sometimes. I suspect the problem is related.


Seemed resolved for awhile.

And somehow knows to fail everytime when I am at the front of a line and need to get to an app to pay.

I’m not taking it personally though…

Just got finished with Apple Support via Chat for this issue.

I think it’s fixed!

Turns out all that was necessary was a “Reset all settings” action (Settings → General → Reset). Something must have junked up the search settings in the past, and that issue was carried forward in every new setup because I always restored from a backup.

I’ll report back if it fails again, but it seems wholly solved. Woohoo!