Streamdeck disconnecting after M1 MBA isn't used for awhile

I have a Streamdeck XL, and since moving to my M1 MBA with an external dock (power, video, USB) I’m finding my Streamdeck doesn’t work properly in the mornings. It’s lit up, and the buttons are clearly there, but pressing a button doesn’t do anything.

A reboot solves the problem, but unplugging / plugging the dock doesn’t seem to.

This sounds eerily similar to the issue a number of people were having with external hard drives plugged into hubs.

Anybody else with a Streamdeck having a similar experience? Any thoughts as to a resolution?

Is the Streamdeck plugged straight into the MBA? if not can you try that and see if it still happens?

StreamDeck is extremely finicky with power/USB connections, so if it isn’t directly plugged in, it might not be getting enough power.

I had this happen with a StreamDeck which wouldn’t sleep when the screensaver started, so I had to move it to another USB port.

1 Like

I don’t have the proper cable for that, so it hasn’t been tested. I’ll have to order a longer USB-C cable. :slight_smile:

1 Like

Make sure it is a USB 3.2 Gen 2 cable.

[Update: see correction below]

It has to be 3.2? 3.1 Gen 2 won’t fly? It comes with a USB A to C cable, and the website only lists the interface as USB 3.0.

Yeah that used to happen to me when connected to USB hub. After connecting to OWC dock, it’s working fine now.

ARGH. Sorry. I was focused on the “Gen 2” part and didn’t realize there’s a 3.1 and a 3.2. (What a mess “USB-C” has turned out to be.)

Quoting Elgato Support (via me) from 2019 you are correct, a “USB 3.1 Gen 2” cable should suffice.

FWIW, I think this is the one that I eventually bought because I wanted “USB-C to USB-C”:

Anker Thunderbolt 3.0 Cable 1.6 ft (USB-C to USB-C) Supports 100W Charging / 40Gbps Data Transfer (Compatible with USB 3.1 Gen 1 and 2)

1 Like

StreamDecks not sleeping is why I turn them face down at night. :slight_smile:

Posting back to note that @tjluoma’s suggestion worked. Streamdeck, direct-plugged into the MBA via a proper cable, was the solution. In case anybody wants to know which specific cable it was that worked for me, it’s this one:

1 Like

Glad it’s working for you. Stream Deck is a finicky bugger about its power source.

Though I had seen this thread previously, I hadn’t experienced this issue until today and the computer didn’t even go to sleep.

I don’t know when it happened, but my Stream Deck was working at 9pm when I started my Google Meet call. Now that the call is over, the screensaver is showing and I can’t wake it up. It’s plugged into my CalDigit dock (connected to MBP 14"). Because I ran the cable nicely behind everything, and because the Stream Deck has a built in cable (boo) it’s a real pain in the butt to unplug and replug it.

That’s actually the main thing that talked me into the XL version instead of the smaller one - detachable cable.