The Printer That Cannot Be Networked

So I bought an HP Smart Tank 520. Here are the problems I have had with it to date:

  1. Unable to print from MacOS - tried the last three versions of MacOS too. No drivers. Evidently a long-standing issue w/ MacOS. The solution is always ‘just use AirPrint’ - Great. Did I mention this printer does not have WiFi?
  2. Print server via Raspberry Pi - I actually had this working for awhile, but now it quit and none of my efforts to resolve it worked.
  3. Print sharing from Windows PC - can print only from connected PC, sharing over the local network doesn’t work. iOS printing attempt can’t see printer in AirPrint.

I guess I’ll spend the morning reconfiguring the Raspberry Pi?

I feel your pain. In the past I used HP printers exclusively but after the last fiasco with intentionally bricking their printers if third-party cartridges were installed I swore I’d never buy another one. Plus their software sucks.

If you can return your HP I recommend Epson. We got one of their tank printers and we’ve been very happy with it.

5 Likes

Ordered 4 months ago, Amazon Mexico. Return not going to happen…

HP printers are a pain. I never recommend my clients to buy a HP… On the other hand it makes me money because these damn things need frequent support…

You have to use the HP Smart app from the Appstore and follow their procedure. Beware its a slow a tedious process…

Start by connecting the printer using a USB cable.
Later you can get into the local website to access the printer and setup the WiFi connection.
DISABLE the direct print option.

As mentioned previously, this printer does not have WiFi… thus, using Raspberry Pi as a printer server.

Follow-up - fiddled around with some settings, restarted some things, and now I can once again print from my Mac or my iPhone over the network.

Scanner is unsupported by SANE, so that severely limits scanning options. Not a show-stopper though…

Something I was told by a guy I work with, who runs a commercial printer renting business on the side, is that if you have a mesh network router, connect your printer to a node via ethernet cable. I did this and have never had connection issues with my Epson Eco Tank since.

It was a life-changing tip. I don’t know how many printers I went through before I tried this.

I have neither a mesh network router nor an ethernet port on my printer. ¯_(ツ)_/¯

1 Like

OK sorry I missed that part part that the printer has no networking capabilities. I just looked and the pictures and of this printer and only see a USB port.

Then the first part of my advice should work, to use their app from the App Store.

You might want to reset the printer system on your Mac by right clicking on the printers under system preferences and reset the printer system system before you try again. In addition I would also go trough the printer menu (on the printer) and restore it to factory settings so you have a clean start.

That app does not work for printers without wifi or ethernet…

Now that was interesting. My Raspberry Pi for some reason lost connection to my network so I plugged the printer back into my Mac. I was unaware of the different menu options between clicking and right-clicking on the printer. Resetting the printing system seems to have given me different options when setting up the printer. I can now share the printer on the network!

Unfortunately the option to scan still does not show up in Preview or Image Capture, but based on my research I wasn’t expecting it to…

1 Like

Open the image capture application on your Mac and check if you can see the scanner.
If not return to the HP application and see if there is more software to be downloaded.

I mentioned and send the link for the App Store on your Mac not iOS. Once you do that and connect with USB the printer will be found (eventually) and install all their software and drivers.

Sad, but that’s why I stopped using Epson: bricked for 3rd party ink.

I am attaching a screenshot so that you can see that your advice is absolutely not correct. Keep in mind, this is a Mac Mini M1 running MacOS Sonoma 14.4.1. The printer is available and works, but the HP Smart app does not see it because the only options to add a printer are for printers connected to a network. ImageCapture does not see the scanner either. So, printing only.

This is evidently a problem between Apple and HP. Apple’s last driver update is 5.1.1 and only works on MacOS before Monterey. Any newer versions of MacOS can only utilize HP printers/scanners that are AirPrint compatible.

My printer has no network connectivity so is obviously not AirPrint compatible.

1 Like

That wouldn’t apply to a tank printer though…

One more data point.

In my previous post the screenshot shows that the system has recognized the printer. However, if you look at the details, you can see that the ‘Kind’ is listed as ‘Generic PCL Laser Printer’ and, as you might expect, this means that it won’t print in color.

So basically I either have to sell this printer to someone locally, or I have to use it on a different computer. What a freaking pain in the ass…

True, but it showed me that I don’t want to deal with Epson for any reason.

I have seen with HP modern printers that are dependent on the HP Smart app is that they will not scan at all unless they are connected to the Internet and logged into an HP Connected account.

I hate modern HP printers and especially the HP Smart app!!

1 Like

While this is true for the Mac, it is not true for Windows. I have full print and scan access on Windows without logging in to my HP account. But, iOS can’t see it unless I somehow manage to get AirPrint working on Windows, which has proven equally problematic.

So basically I’m stuck between a rock and a hard place. SIGH