Unable to add accessories to HomeKit — new problem with iOS 16.1?

I’m wondering if anyone else has run into this issue, and if so, if you’ve found a solution.

For whatever reason, my Harmony hub recently stopped working with my Google hub. (Google thinks it’s turning on my Watch Apple TV activity, but nothing actually happens.) That’s fine; I’d just as soon connect the hub to HomeKit, anyway.

And there’s a lovely Homebridge plugin that does just that: Homebridge Harmony.

The problem is this: I can’t add new accessories to HomeKit. They keep timing out as unreachable. If I’m recalling the timing correctly, this problem is new with iOS 16.1. I didn’t have the issue when I rebuilt my Homebridge server over the summer, and I was running the betas then.

I saw a similar issue when I tried to move my Ring system onto a child bridge last week. I couldn’t add it to the Home app with the new HomeKit code. As soon as I got stopped running the Ring plugin as a child bridge, everything worked just fine again.

Homebridge Harmony doesn’t need to be run as a child bridge; for my use case, it’s actually better if it isn’t. But it does still require adding the accessory I set up as a new item in the Home app (oddly, using the main Homebridge HomeKit code). So I’m stuck with the same problem — I can’t add new accessories. When I try, the Home app eventually times out, telling me that the accessory is unreachable. (What’s really maddening is that, once I’ve set things up in Homebridge, the Home app sees the TV activity as a nearby accessory. It just won’t talk to it.)

This is a minor matter, I know (I do, after all, have a remote that I use regularly). It’s still driving me slightly bonkers.

Has anyone else run into this sort of issue?

Is it possibly a network issue? All devices must be on the same network. Ther are a bunch of WiFi networks where I live and sometimes devices / accessories drift to the wrong network.

Thanks! But yes, everything’s on the same network. I’m at home, and while I can see my neighbor’s networks, none of my devices have ever been introduced to them.

I do have two Eeros — the main gateway and one extender (which gets the signal out to the garage). I suppose I could try unplugging the extender to see if that makes a difference. You wouldn’t think so, but who knows?

I’m experiencing this, but I was thinking it was specific to the device I was adding. Will try again later.

And you’ve checked for firmware and app updates? I don’t mean to state the obvious, but I generally try for simple soft fixes first, before hardware.

I’ve had problems adding a Meross MS220 after it reset itself, I’d put it to one side, but seeing this post reminded me.

I’m also on an Eero network, so I switched off the guest network and reset the plug again, and it added quickly and easily.


Yep — everything’s up to date.

Thanks, all, for the replies.

I’m still mystified, to be honest (so thankfully the problem’s a minor niggle, rather than something major).

I’ve thought about removing Homebridge itself and re-adding it, but if the issue really is iOS 16.1, that could go really sideways — I could see the same behavior trying to re-add Homebridge, and lose access to all the plugins there.

It’s probably best to just wait for 16.2 and see if the issue resolves itself. :slight_smile:

Agree with waiting, but a possible interim less drastic solution than removing Homebridge might be cycling the power ?

I’m afraid I tried multiple versions of that:

  • Restart Homebridge
  • Restart the Raspberry Pi on which Homebridge runs
  • Restart my network
  • Restart my phone

No joy. :frowning:

1 Like

An update:

I’m still not sure why I had to get Ring off the child bridge and back onto the main for those accessories to connect.

But further digging turned up why the Harmony hub wouldn’t connect. It was a port issue. As soon as I opened the necessary ports on the Raspberry Pi, it connected just fine. :smile:

1 Like

Your intuition is correct. Do NOT remove Homebridge, you will likely also be unable to reconnect it as an accessory.

I had a similar issue, a few days ago my Levoit air purifier, connected through Homebridge, stopped responding. I tried removing and re-adding Homebridge, but HomeKit says it cannot find the accessory when trying to add it back. So now I cannot even reconnect Homebridge.

I’ve found 2 other people who ran into this problem and were able to re-add Homebridge to their home using an older iPad that hadn’t been upgraded to iOS 16 yet, and then Homebridge works fine even on devices running iOS 16.

That suggests to me that some part of accessory connection to Homebridge broke with a recent iOS 16.1 update, and so there’s not much anyone can do until it’s fixed on the Homebridge or Apple side.

1 Like