Universal Control Stopped working?

Running on MacOS 12.4, iOS 15.4.1 and Universal control has stopped working. (It has worked before so this isn’t a device limitation).

Sidecar works, handoffs work. I’ve done all the troubleshooting suggested here: Universal Control Not Working? Here’s How to Fix It - MacRumors


Handoffs are enabled

On the iPad side Handoffs are enabled and I’m signed into the same iCloud ID. iPad and Mac are using the same WIFI and bluetooth is turned on. Devices are less a foot apart. I’ve rebooted both multiple times. The iPad isn’t on a cellular connection.

Have I misplaced my brain? Is this just a known bug?

Curious and confused in Ottawa

I have the same problem - but only with one of my Macs.

I presume it is a conflict with some software on that computer (perhaps related to Bluetooth communication) but I have not been able to figure it out.

1 Like

Same for me. It was working fine up to a week ago. Haven’t used it sense then and today I couldn’t figure out what was wrong. Switched off all the settings on MBP and iPad. Toggled Bluetooth, ensured I was signed in to iCloud on both, then messed around with handoff and rebooted everything but no dice. Am updated to latest softwares.

Coincidence? Glitch in matrix? ¯_(ツ)_/¯ who can say?

1 Like

I’m relieved to hear that because I have the same problem. Tried everything short of signing out of iCloud. Pretty sure it’s a bug.

1 Like

Glad I’m not alone. Will wait for 15.4.1

I’m on macOS 12.4 and iOS 15.5 and Universal Control is working for me.

From Apple’s UC web page:

" * Make sure that each device meets the Universal Control system requirements and is using the latest software updates for Mac and latest software updates for iPad."

So maybe macOS 12.4 and iOS 15.4.1 are not in sync? And you need to update to iOS 15.5?

Also just to make sure, you have selected your iPad in the Displays system preferences in the “Add Display” dropdown list:

I’ve found that this selection is not always persistent.

1 Like

@Mevet thanks. First - my what a large number of displays you have :wink:

Add Display - I can do that, however all I get is a SideCar display.

iPadOS 15.5 - didn’t know it was available, it was advertised to my iPad although as soon as I searched for the update it found it. Downloading and installing now. Wish me luck.

I also have 4 monitors. I wonder if that a clue to why this does not work for some people.

I would probably have two monitors, however I need my monitor to move between the treadmill and chair sides of my desk:

FWIW Updating my iPad to 15.5 fixed the problem. MacOS 12.4.1 apparently requires 15.5 for Universal Control to work. Too bad that 12.4.1 was pushed at a different speed than 15.5.


Universal Control stopped working for me when macOS 12.4 was installed. I upgraded my iPad to 15.5 and that restored the functionality.

1 Like

Basically my experience.

1 Like