628: Stream Deck Power Users

I’m loving my Stream Deck, but I’m having an issue I don’t know how to deal with: Text Expander Snippets-when I type the TE snippets into the SD program, they expand. That’s fine for ones without variables, but some that I want to use do (like my insert date and time stamp. Can’t figure out how to make that work.

I like the idea of the Stream Deck, but wasn’t sure about spending the money on it without experimenting with the concept first. So I thought I would try the Stream Deck app… Meh. It wasn’t a great experience and given that it only works on the iPhone it really isn’t intended for a desk-top installation.

I had an older iPad Pro lying around and that is what I imagined I could turn into a “stream deck”. I found Touch Portal and started playing with it. It absolutely works as advertised. So well in fact, I have lost interest in Stream Deck. Touch Portal can can work with a lot of different platforms, apps and devices (including Hue lights/bridges). What it doesn’t work with can be accessed through Better Touch Tool or Keyboard Maestro. I have multiple screens that I can access from a “main” screen; I really like how the screens can be quickly referenced - gone is the need for me to remember a bunch of keyboard shortcuts. I am doing app control, system control, window sizing and context changing with Touch Portal. Icons can be attached to the “buttons” on each control screen. When I get an idea for some new buttons, I quickly set them up with text only and make them look nice later (I am falling behind… :roll_eyes:). Toggling buttons and sliders can also be set-up on the control surface.

The biggest downside to using Touch Portal on an iPad is the lack of tactile feedback. On an iPhone you can optionally activate haptic feedback, but let’s face it; there isn’t that satisfying, button pressing feel with Touch Portal like you would get from a physical Stream Deck. I’m okay with that; some would find that a show stopper.

You can use iOS or Android devices for the control surface, while the host app where you create the various panels is available for Windows or macOS. There was a hiccup when Monterey came out but the developer corrected that fairly quickly and has been updating steadily since then. Pricing is reasonable and is not subscription based, although it would be okay with me if he went to that model. I think there is a lot more value in the Touch Portal solution than the Stream Deck App (which is subscription based).

It’s a highly flexible control system that provides a ‘Stream Deck-Like’ experience. If you have a spare tablet or old smart phone lying around, Touch Portal may be worth a look.

3 Likes

Wow, very interesting since

Touch Portal runs on Android 4.1 and up and on iOS 9.3 and up.

I might finally get more use out of my old iPad or iPad mini.

I’m going to be in the centre of Dallas in late March and highly inclined to buy the XL (having the 6- and the 15-button ones already). I won’t have a car. (Backup scenario is near Poughkeepsie early April.)

I have two questions - that I hope others will find relevant:

  • Who in such a city centre environment is likely to carry a Stream Deck XL?
  • As I (hope to) travel a lot (again) any tips on how to travel with a Stream Deck (XL)? Pouches, etc?

Best Buy or Target, you can pre-order so the store has it ready for collection. But don’t forget Amazon can also deliver to an Amazon locker for you (aim to have it arrive mid-end of your trip, if you aim for it to arrive at the beginning of the trip then Amazon will magically give you amazing service and deliver it 3 days before you arrive resulting in it being returned to Amazon before you can pick it up!).

If you’re not looking to travel with the stand (which is not foldable and takes up quite a bit of space), or don’t mind having that in a separate bag/pouch, I’d recommend looking for a 2.5" harddrive case, it will comfortably hold the Stream Deck XL, as well as the cable (or a different cable which is coiled and springy) and likely some other things (1TB SSD, or similar?). Fortunately, those are very cheap and easy to come by on Amazon.

For reference, here are the dimensions of the Stream Deck XL without the stand:

  • 18.2cm wide (7" 5/16)
  • 11.2cm tall (4" 3/8)
  • 3.7cm thick—though I’d allow for 4cm as that’s not including the buttons (1" 5/8)

Apologies to everyone for mangling the inches and fractions, I never use them!

3 Likes

That’s because they’re dumb. :wink:

I wouldn’t have thought about the hard drive case for portability. That’s a great idea, thanks!

1 Like

That was my tune for over a year. I finally bought one a couple of months ago and I use it way more than I expected. In fact, you couldn’t pry it away from me now.

Two thumbs up for Button Creator. I’ve been using it for a couple of months as well and it is terrific, I’ve used it for every button I’ve made on the Stream Deck. It’s so easy and fast, and all of my buttons have a consistent, clean look.

Hi Gang,

In the streamdeck episode I think @MacSparky was talking about having custom scripts for going in the right folders in Mail App on the Mac. While I managed to do this by adding those folders (SaneLater, SaneNews, Sanebulk…etc) to the favourites and using ⌘+ numbers, I think the script version is a much better approach. Can you guys share links or guide me in the right direction? Thanks:)

FYI folks Stream Deck on sale!

Elgato Stream Deck - Live Content Creation Controller with 15 Customizable LCD Keys, Adjustable Stand, for Windows 10 and macOS 10.13 or Late (10GAA9901) Amazon.com

Anyone else having this StreamDeck issue in MacOS Mail and Notes? After listening to this episode l decided to ramp up my usage on my Stream Deck. I added text shortcuts…just using the text function on the Stream Deck. When in an email i click the button ie my email address and it adds Aa to the first 2 letters. Only happens at the start of a newline…and only in Mac Apps…like Mail and Notes. Works perfectly in chrome, word etc. I am only using shorts snippets - email - web address - home address but it happens with them all. Yes l can use TextExpander but almost quicker to use a button as some apps/sites won’t accept TE, Hope someone has a suggestion. Thanks

You can subscribe to the Mobile/Soft version of Stream Deck. Gives you a fully functional 15 button “Virtual” Stream Deck on your phoneiPad etc.
I do this as great for use with my MacBook while travelling.

Stream Deck have a mobile version that you can subscribe to. Not sure device requirements but gives you a fully functional 15 button Stream Deck.

Thanks Sue. I did give the mobile version a try. But it didn’t work for me. I tried it on my phone, but I’m often using the phone for other things, and the appeal of a “bunch of buttons” is that they are always available.

I also looked at Metagrid and Touch Portal. And I settled on Touch Portal.

The main reason is that I have an ancient iPad Air, and while the older version of Metagrid will run on the Air, Metagrid Pro, which will not, is the one that will be getting the most development work done to it going forward. Touch Portal on the other hand has one version that works with the Air and was updated just this week.

And it also helped that Touch Portal had a free trial version, whereas Metagrid does not, and Touch Portal is cheaper.

So I am now using the old Air, which had been gathering dust, as my “bunch of buttons” device.

1 Like

OK, i know i should have backed the profiles up…

I was loving getting to grips with my top spec 16” M1 MacBook Pro until it started crashing, big time. Long story but ended up being a corrupted SSD that could not be repaired using disk utility.

So…. Yep, wipe and re-install. Of course i had a bang up to date time machine backup. So restore should be easy, right?

Well, try as i might, but dragging the elgato preferences from my library on the backup didn’t work. When i restore an old profile, i get lots of keyboard maestro icons on the stream deck but not pointing to anywhere. Strangely, my wallpaper (a nice shot from blade runner 2049) restored but nothing else!

Any suggestions, or do i have to start again from scratch?

@BurntNorton I’m not certain, but one thing I have noticed when using the KMLink plugin to directly execute a KM macro by name is that if I change the name of the KM macro, I have to edit the associated button the StreamDeck. However the link to the KM macro is made, it seems to get lost in the process.

If your only issue is your buttons that connect to KM macros, you might be able to fix things up just by going through each button and “relinking” them to the correct macro. Tedious but better than recreating the entire layouts.

I would have expected that restoring the preferences file would have restored all profiles and buttons otherwise, though. If that did not work, maybe exit and restart StreamDeck? It might have a problem with recognizing that the prefs file was replaced and not reload properly?

thanks @nlippman I’m out of the office today, I’ll give your suggestion
my problem is I spent ages creating 8 custom profiles, and only backed up the first three… when my Stream Deck reset to the one ‘welcome’ button on reinstall, I was worried! That’s when I copied over all the folders from ~/library/application support/elgato/streamdeck (etc…) from my time machine backup. there must be some preference files somewhere else (virtual key allocation, icon associated with each button, etc) because restoring these directories and files made no difference.
Then I went back to restore the 3 profiles I backed up. and this is when I got the stream deck buttons populated but only with the KM default logo and no connection to the Stream Deck.
I’m worried that I’m going to have to start it all again…
Anyone got any experience contacting elgato direct?

I recently moved my StreamDeck to a new computer. I copied over:

	"$HOME/Library/Preferences/com.elgato.StreamDeck.plist"

	"$HOME/Library/Application Support/com.elgato.StreamDeck/"

(The second one is a folder) and everything worked as it had on the old computer. And by everything, I mean all profiles and buttons that were linked to Keyboard Maestro macros worked fine.

2 Likes

Yes. I believe you need the preferences file.

Have you reinstalled the plugins those buttons link to?

2 Likes