64-bit Fujitsu driver works with old ScanSnap!

The main thing that’s stopped me from upgrading to Catalina on my iMac is the lack of 64-bit driver support for my sturdy old ScanSnap 500M.

Official support for the scanner ended long ago, but I haven’t given up hope. Every few years I’ve been scouring the Fujitsu website for new software, and occasionally I’ve been able to download software for more recent ScanSnaps and install it successfully.

For the last year or so I’ve been running version 6—but last night an alert popped up on my iMac screen (running Mojave) saying something like “ScanSnap V7 is now available. It includes support for some older scanners.”

That last cryptic remark sparked my interest. I clicked the Update link and was taken here. No mention of the S500M.

I didn’t let that stop me. I clicked the link for the oldest scanner on the list, which I think was the S1500M. Download and installation went perfectly, and the scanner still works—the software looks exactly the same as it did before.

Then, the real test: I installed the same software on my MacBook Pro with Catalina installed. Success! My ScanSnap now works in Catalina (if you check in the System information app, all of the ScanSnap software is now 64-bit).

In both installations I had to fib and tell the installer that my machine was newer than it actually is—but that’s always been the case when I install relatively recent Fujitsu drivers.

Give it a try!

7 Likes

An update to run the old ScanSnap software (but a 64-bit) was pushed out recently and I got the notice only last night. I declined to install right away, but I’m seeing other people saying it’s the old interface, but updated.

Odd choice on Fujitsu’s part, that for me anyway invites further skepticism about their reliability in future OS updates.

Given all the complaints I’ve seen about newer SnapScan interfaces, I’m content to stick with the old one.

Mostly, I’m just happy that my old scanner will still work with newer system software.

Of course, I haven’t tested it in Big Sur yet…

1 Like

I cannot figure out how to download 64-bit ScanSnap Manager. Everything ends of leading me to ScanSnap “Home”.

Anyone have a direct link?

If you follow the link I provided, click the link under “ScanSnap Manager V7 download page”, namely this.

You’re right, if you click the second link on the page (“ScanSnap Manager”) it just takes you to a marketing page.

2 Likes

Thanks! I got them. I think. I’ll have to try setting it up later today.

I really want to find whoever is responsible for these filenames and the website design, wrap them in a blanket, give them a nice warm beverage, assure them that they are in a safe space, and then ask: "Who hurt you? Who made you like this?!"

Because their website and filename/versioning is absurd.

(ScanSnap is also the software that had scan-quality levels something like: “Good, Better, Best, Even Better” which always made me want to pull out my hair out and say You cannot have a level above ‘best’!!!)

Anyway, when I download from Fujitsu’s website, I always make sure to put the download in a folder with the name of whatever it is suppose to be, and then I put a text file in there with the date I downloaded it and the URL that it came from.

Direct Links for ScanSnap iX500 Owners

At least for the time being, these direct links work for downloading the named programs for the ScanSnap iX500 which is the model I have. I don’t know if they actually differentiations for other models or not. or if their website just makes you jump through different hoops for them.

ScanSnap Manager V7.0L20 Setup Program

MacManagerV70L20WW.dmg (998,038,301 Bytes or 998.03 MB)

ScanSnap Online Update V3.1L10 Setup Program

MacOnlineUpdateV31L10.dmg (5,708,347 Bytes or 5.70 MB)

ScanSnap Installer Setup Program

MacSSInst2iX500WW.dmg (916,118 Bytes or 916.11 KB)

3 Likes

Is it necessary to uninstall the older Scansnap Manager software before installing this new version? Neither the installation instructions nor the Readme file mention this.

Any other requirements? I assume that you should “quit” Scansnap Manager if it is already running.

Thank you for your post - very helpful.

Worked for me, thanks! I was using an old Mac mini just for scanning, now I need to figure out a new purpose for it (other than keeping it for scanning once scansnap doesn’t work on Big Sur!).

I can also confirm this seems to work great with my ix500. I’ve got it hooked to my Mac mini which is still running Mojave, but it’s 64-bit so assuming that I do eventually “upgrade” this mini to Catalina, it will still work.

Excellent news. Thanks for sharing it!

Amazing move, and solves the license issue for using ix500 and earlier on more than one computer. But at least for me, I’m liking the new software much better than the old since they’ve gotten the bugs out of it and I’ve figured out how to configure it.

Downloaded the installler on my Mac mini running Catalina and on my 16” MBP running Big Sur. My ScanSnap S1500M is workng just fine.
Thank you @VictorGav

Thank you @VictorGav for sharing. My 9 yo S1300 is still getting the job done.

Thanks @VictorGav.

I installed it this morning on the newer of my two MacMini’s. My S510M is now running and saving directly into DEVONThink Pro again on that newer Mini rather than having to work on my older 2009 Mini and then sync through Devonthink Pro. Thanks for posting the info. :smiley:

Thank you @VictorGav. I was minutes from purchasing the $120 ExactScan version for my S1500M.

In celebration of saving that money, I signed up for as an MPU Relay.fm member (I would have probably done that anyway)!

1 Like