Anyone using Scansnap with Mojave beta 3?


#1

I didn’t have any issues with betas 1 or 2, but with 3 Scansnap OCR is running ridiculously slow.

Anyone have this issue? I’m all up to date on Scansnap and I can’t find any public beta versions.

Of all the things to fail 3 betas in…

Thanks for any help!


Fujitsu ScanSnap and Mojave
#2

I can’t talk to Beta 3, but it is a beta so I’d expect there to be some volatility in how well it works. Beta 4 may fix any issues you see…or maybe beta 5. Either way, submit feedback to Apple.

And please tell me you’re not running this on a mission critical system.

Ben


#3

Nope. Just my secondary computer. But it is where I run Scansnap. So I’ll just batch OCR them for now, assuming that’s any faster than the usually zippy inline OCR during a scan.


#4

My advice would be to expect issues when running a beta, and report them to the developers.

Have you sent your findings to scansnap?


#5

I believe that ScanSnap is 32-bit. Perhaps this type of behavior is what Apple has been warning us about re: 32-bit apps not functioning properly in the future?


#6

I believe that the 32-bit restriction does not happen until the MacOS version after Mojave. Mojave just warns you and asks you to notify the developer. Who will just :::LOVE::: all those notifications, LOL.

I was asking in case there are other Scansnap users here that are on Mojave beta. That way, I can debug knowing whether it’s a local issue for me or there are others experiencing the same bug.

I bet Scansnap Ninja @MacSparky has an instance of Mojave running. Just sayin, David… :slight_smile:


#7

Probably does, but he is also a lawyer and I’d expect not about to break the NDA. :smile:


#8

Maybe its something with 64bit? Because the update for ScanSnap is still not out.


#9

There’s no NDA on the dev beta as far as I know. Heck, the public beta is the very same release.


#10

I wonder if this tweet from SuperDuper’s Dave Nanian may offer a clue: This might be related to the tighter permissions and security in Mojave that an app could address directly after an update, but may need a workaround until.

If you’re trying to use SuperDuper! 3.1.7 with the current Mojave public beta, please add us to

System Preferences > Security & Privacy > Privacy > Application Data

That should allow us to work.

I plan to mess around with it when I’m back home later this week.


#11

I am running the Mojave public beta v3, and ran into the same problem yesterday. The OCR takes forever. Will try the workaround mentioned, and let you know if it helps at all.


#12

I read this:

You agree that the Pre-Release Software and any information concerning the Pre-Release Software (including its nature and existence, features, functionality, and screen shots), the Seeding Tools, and any other information disclosed by Apple to You in connection with this Agreement, including but not limited to information learned by You from Apple employees, agents or through inspection of Apple’s property, that relates to Apple’s products, designs, business plans, business opportunities, finances, research, development, know-how, personnel, or third- party confidential information disclosed to You by Apple, will be considered and referred to collectively in this Agreement as “Confidential Information.” Information that otherwise would be deemed Confidential Information but (a) is generally and legitimately available to the public through no fault or breach of Yours, (b) is generally made available to the public by Apple, © is independently developed by You without the use of any Confidential Information, (d) was rightfully obtained from a third party who had the right to transfer or disclose it to You without limitation, or (e) any third party software and/or documentation provided to You by Apple and accompanied by licensing terms that do not impose confidentiality obligations on the use or disclosure of such software and/or documentation will not be considered Confidential Information under this Agreement. All Confidential Information remains the sole property of Apple and You have no implied licenses or other rights in the Confidential Information not specified in this Agreement.

I’ve heard that the public beta has an agreement as well. Of course that doesn’t mean that anyone is actually taking this seriously.

Here’s the FAQ mentioning the confidentiality agreement for the public beta:

Is the public beta software confidential?
Yes, the public beta software is Apple confidential information. Don’t install the public beta software on any systems you don’t directly control or that you share with others. Don’t blog, post screen shots, tweet, or publicly post information about the public beta software, and don’t discuss the public beta software with or demonstrate it to others who are not in the Apple Beta Software Program. If Apple has publicly disclosed technical information about the public beta software, it is no longer considered confidential.


#13

Any resolution to this? SnapScan is my main reason to hold back on Mojave.

Despite my great love for the ix500, it seems like their software has gotten little love in the past couple of years.


#14

Checking back to see if anyone is using Scansnap succeessfully with Mojave. It seems like Fujitsu is slow to update each year.


#15

I think they wait for the final release of Mojave before they send out there own update.


#16

Just checking back to see how the latest beta is playing with ScanSnap software. Any new feedback? I love my Fujitsu, but is it just me or is there support of the software waning? Last time I checked it was still 32 bit as well, although my understanding is that this is still OK with Mojave.


#17

Another voice of concern regarding ScanSnap software support for macOS.

Back in January of 2017 I contacted Apple tech support and Fujitsu tech support regarding problems with PDF files created by the ScanSnap, associated with macOS Sierra 10.12.3 release. Among other problems, the OCR layer was broken - no files could be created with OCR support. Later, in Nov 2017, with macOS High Sierra, PDF files created with the ScanSnap were corrupted by out-of-order pages. I have been told that these problems were due to Apple’s new implementation of PDFkit, the macOS software that supports PDF files. These problems were resolved eventually, but a few bugs persist even today.

A Fujitsu tech support rep, after some delay, advised me (by email) to download and install version 6.3 of the Fujitsu software, designed for the iX500 model. My scanner is the S1500M model, for which the latest software support posted on the Fujitsu website is version 3.2, apparently from several years ago.

This, along with comments from others above, makes me concerned about ongoing support for the ScanSnap line for the Mac. If macOS Mojave “breaks” the Fujitsu drivers again, I will have to choose between keeping the Fujitsu scanner and updating to macOS Mojave.

Someone, elsewhere in this forum, suggested using the scanning software VueScan with the ScanSnap scanner. Does anyone have experience with this?


#18

Still the MPU team keeps on telling how great the Fujitsu ScanSnap software is. Which it actually isn’t (IMHO).


#19

I’m using Vuescan with my old Epson Perfection 4870 Photo flatbed scanner and still running ScanSnap with my S510M. I can do a vew quick tests to see if I can run VueScan with the ScanSnap scanner later today and report back.

Edit
Decided it would take only a few minutes so tested it:
VueScan works well with teh scanner, recognized it and all its features upon startup with no problems. However it does not appear to connect to the OCR options at all. Since OCR on the ScanSnap is separate SW I am not surprised. I never use OCR on scanned documents so that wouldn’t bother me but YMMV. I think you can work on getting the OCR to work outside the actual scanning but I don’t know how.


Mac Power Users 464: Stephen... Who?
#20

Please note that last time I checked Vuescan was not working for all ScanSnap models.