Citrix Workspace and the latest version of macOS

Hi all, I titled this generically since I have this problem every year. I’m tempted to use the new public beta of macOS (this year Monterey, last year Big Sur) but can’t until I’m sure that it will run Citrix Workspace. The Citrix website says…

Citrix Workspace app for Mac on macOS Monterey Beta

Citrix Workspace app 2109 for Mac has been tested on macOS Monterey Beta 7. Please use this setup in a test environment and provide your feedback.

…whatever that may mean. There was a similar post last year by @jahala. I’m guessing you’re in the same boat again this year.

Has anyone tried Citrix Workspace v2109 on Monterey, yet? Thanks.

I decided to skip the beta this year. I’ll test Citrix Workspace as soon as Monterey is released.

1 Like

I use Citrix on Monterey every day and it works fine, with ONE really annoying problem for me. I cannot get my remote machine registered in the app. I have to go to our citrix website, download the file, and launch that. It runs fine and works as normal other than that. (Technically, I guess, the machine is running in Citrix Receiver, which is a component of Citrix Workspace.) Forgive me, if these are not the proper technical terms for describing the process. I’m not entirely certain of all the lingo surrounding virtual machines.

Also, I think I was having this same problem under Big Sur. I don’t think this was some new beta issue. It could also have something to do with the IT policies at my firm and not a failing with Citrix Workspace or its interaction with Monterey.

1 Like

That’s encouraging they even mention Monterey before release. I’m on 2107 because 2108 had a really annoying feature where it would insist on a login way too often. In my case it was once mere seconds after I had logged in, but usually around half a dozen to a dozen times a day, whether you tick “Don’t ask for 7 days” or not.

I created a Big Sur bootable USB installer (just in case) then installed the Monterey public beta. Citrix Workspace seems to work fine so far.

Has anyone tried Citrix Workspace this year with the latest macOS Ventura beta?

I daren’t! Thanks for reminding me not to leap on the release this year.

I did after reading on Reddit that it works and can confirm that it does indeed work.

1 Like

Thanks, good to know! I do wish I could figure out how to Alt-Tab with it. It seems like it’s a thing that used to work from what I’ve found online. Just not now, or at least not for me. I have at least discovered that (Left)Ctrl-(Right)Cmd-arrow (left and right) will switch between desktops, which is acting as a reasonable stand-in for now. Though I’ve had to put stickers on those two modifier keys to reliably hit them.

1 Like

Use Option+Tab. Let me know if that doesn’t work.

Bonus: Ctrl+alt+delete = fn (siri button) + ctrl + opt + delete. The citrix manual says fn + command + delete should work alone, but that has not been my experience.

One last one, that maybe you know. If you want to access all your desktop and you have your right command button set in preferences as the Windows button, you can do this:

fn+tab+command(right). Will open the desktop navigator.

1 Like

I’m pretty sure it doesn’t, though I haven’t tried it recently. Last year I spent a lot of time researching how to do it and found all sorts of solutions on which keys to press, which configuration options to use in both Workspace and macOS and none of it worked.

This one will be useful. I generally don’t need it day to day, but the other day I wanted to change my password and … for reasons … wanted to do it that way and could not figure out how. Fortunately I was due in the office before it expired so was able to do it natively.

Also useful, thanks!

I will give all these a try a bit later.

Does not work with either Option key. It just behaves like the Tab key.



The Ctrl-Alt-Del one will certainly be useful for password change time. The desktop navigator I don’t generally have a problem clicking on the icon as it’s an occasional thing. It’s the Alt-Tab that I would use all the time.

1 Like

Please post a screenshot of your keyboard settings.

Pretty sure I’ve tried all the combinations but happy to be proven wrong.

I suspect (don’t know) that each institution may have its own limitations on what Citrix will and won’t allow. I also can’t get this to work, but I bet it’s on my institution not anything with Citrix or my settings.

We have a small number of Mac users in our company, and I and some other Apple geeks were trying to help one of them out when she was having issues getting something to work. One of the helpful “End User Compute” chaps, who I have dealt with before, made the helpful statement that “Macs aren’t really designed to work with Enterprise.” I politely corrected him that he had it back to front. I mean, if a wee company called IBM can manage it at scale, I think we can if somebody cared to.

So yeah, it wouldn’t surprise me. If I knew there was such a setting, though, I would most certainly agitate for change!

Sorry was in trial. This is strange because your keyboard set up looks identical to mine. Is it possible you have another shortcut on your Mac that conflicts with this in Citrix? I wouldn’t be belaboring this point on this thread, but I know how reliant we can get on alt-tab window switching In Windows. So, an equivalent that works in Citrix is critical.

I cannot find anything in all the sections of macOS Keyboard preferences. I did just try something which suggests @oldblueday’s comment is on the money. In the Devices > Keyboard > Send Key menu, if I hold down the Option key, there is an ‘Alt-Tab’ entry. I clicked this and it entered a tab in my OneNote text that was active at the time.

Just upgraded to Ventura’s latest beta (13.1?) and Citrix is not working with this for me. :frowning:

EDIT: after searching around I found a Windows 10 user with the same issue. They had scaled their display differently from the default. Going to the default and back again fixed it. Just in case anyone has the same issue.

EDIT 2: this behavior only seems to happen when connected to a second monitor (either via cable or the iPad acting as a second monitor). ¯_(ツ)_/¯

I upgraded to Ventura yesterday and have used Citrix Workspace successfully a couple of times with my workstation that is configured as a Desktop, not a remote App. See screenshot below to see what I mean.