Hyperkey by Ryan Hanson

Just stumbled on this app, “Hyperkey”. It’s 4.99. It’s exactly as it sounds. It replicates the famous Caps Lock → CMD+OPT+CTRL+SHIFT modifier (normally done with Karabiner) within a nice GUI. There are also some added niceties that some might like, like the ability to create a “Hyperkey” gesture on the trackpad.

I’m still using Karabiner Elements because I also map Caps Lock to some VIM navigation shortcuts, but this is a solid route to go if you don’t need that control. Much easier than trying to figure out Karabiner. :blush:

3 Likes

Can you still use the caps lock touch otherwise in the normal fashion? (that is, used on its own, not simultaneously with another key?)

For folks looking for a more user friendly way to enable the Hyper key than Karabiner, Better Touch Tool also supports it.

3 Likes

I’m not sure I follow. Here’s a screenshot of the preferences. This might help answer your question.

1 Like

Thank you! Looks like it’s the case (you can still quick press the key to use it as it is intended). Will definitely take a close look at that one.

1 Like

Does it disable the Caps Lock LED?

(BTT unfortunately does not; Karabiner Elements does)

For some reason HyperKey with BTT was a disaster for me, just didn’t work properly and caused issues.
Karabiner has been flawless. odd.

1 Like

I haven’t installed it yet but I wrote the developer and he said it’s fully disabled for long presses but enabled if you activate Caps Lock mode.

EDIT: Sorry, I misunderstood the developer. He clarified:

Just wanted to be clear that when the quick press is set to Caps Lock, the long press will result in the light turning on then off. Although I think it is possible to obtain the desired behavior where it would only go on for a quick press, I just haven’t gone down that path yet since I haven’t had much feedback looking for that functionality and I find it best to start with less complexity until otherwise needed. I’ll revisit this in a future release and see how it goes.

1 Like

Thanks for this @kennonb! It seems to do exactly what I want, and could never get KE to do (which I think is also what @KillerWhale wants).

1 Like

This app does the same as BTT does when trying to use the HyperKey.

I use KBM that when hyperkey+t is pressed it copies the text, opens task manager, creates a new task and pastes.
Works flawlessly with Karabiner but this app and btt spends 10 seconds flicking between the two apps before pasting into the app it’s copying from. very odd.

Ah ok. That’s disappointing. I wonder if it’s because Karabiner is creating an actual virtual keyboard and remapping, but likely this is just handling it via some higher level software implementation?

Do you have Hyperkey, BTT, and KE all installed at the same time?

It does do this but I can live with it.

I uninstalled KE and rebooted before installing Hyperkey, can’t remember when I tried BTT

The last time I tried to uninstall KE it wasn’t completely successful. Of course that may have changed.

From your previous post it seems you’re trying to use BTT and Hyperkey together. You might email the dev to find out if there are any known issues with that.

Can you set the Caps Lock modifier key to “No Action” with Hyperkey?

(I can with Karabiner Elements, but not with BettterTouchTool)

Yes, you can set Caps Lock modifier key to “No Action” and Hyperkey still works.

Bonus: the LED will stay off! :smiley:

I’m stoked I stumbled on this thread. I clicked just to vouch for the developer. He recently released an app called Charmstone, I emailed him a suggestion to add arrow key navigation to it, and he had it up within a few days despite some sandbox challenges with the MAS.

But now I’ve gained something myself after seeing others mention BTT Hyper key trouble. I’ve been using BTT’s Hyper key for a while, with it working only half the time. Never dug deeper, figuring it was just the nature of remapping so many modifiers. But I just tried Hyperkey and it works every time for me.

1 Like

Mr. Hanson has fixed the Caps Lock LED issue; a quick press will light the LED and enable Caps Lock, while a long press will leave the LED off.

2 Likes

I noticed this on the last day of my trial. It’s now exactly the way I want it!

If Karabiner Elements ever gives trouble (which might be after a major macOS update) I can switch to this Hyperkey App :smiley: