iMac failing to boot

This afternoon my 2017 iMac 5K crashed. Upon rebooting, it hung up with the progress bar about halfway across.

System: 2017 iMac 5K, macOS 11.6.4, 1TB SSD (added in response to @MacGuyMI)


  1. Booted into recovery mode. Disk utility shows the internal SSD as “uninitialized”.
  2. Attempted to reinstall the OS. When the Big Sur installer got to the screen where it says “Select the disk where you want to install macOS” there’s just a big blank space.
  3. Attempted to reformat the drive in Recovery Mode using Disk Utility. It quickly gives the error message, “Unable to write to the last block of the device. : (-69760)”
  4. Reboots now give the blinking gray folder with a question mark.
  5. Booting into recovery mode now seems to go to internet recovery rather than the recovery partition. Attempts to reinstall or reformat still fail.
  6. Tried resetting NVRAM. No change.
  7. Disconnected everything except the keyboard and Ethernet. No change.
  8. Removed the two sticks of aftermarket OWC RAM. No change.
  9. Attempts to boot from a clone backup hang up with the progress bar at about 50%

My conclusion is that at the very least the SSD is toast. The inability to boot from the clone backup could indicate additional problems beyond the SSD. That said, I’d welcome any insight from other Mac Power Users who’ve encountered anything similar.

I guess my interest in what new Macs Apple might announce tomorrow has suddenly gotten a lot more urgent. Maybe the iMac gave up the ghost because I talked about buying a new desktop.

Is this a Fusion Drive setup???

If so, the spinning HD is the likely culprit not the SSD. It has been my experience that SSDs work like a light switch… it is on or off. There is no in between for SSDs.

Never mention replacing older hardware in the presence of said hardware!

1 Like

Nope. 1TB SSD. Probably should have mentioned that in my post.

Buy the new computer…

Replacing the SSD through Apple is going to be expensive. $800-900 is my guesstimate. 3rd party SSD at an AASP should be around $400-500.

1 Like

This sounds like a logic board failure to me.

1 Like

I assume you waited a while?
The os might be trying to access the internal drive, and waiting for it to fail 25 Times before giving up.

Would target disk mode buy you anything? I.e. just to see if it will boot that far?

Yes, apparently an iMac has its feelings, too. :thinking: :slight_smile:

1 Like

Have you tried to install MacOS on an external drive?

Looks like that was step 9?

I just let it run overnight. No movement of the progress bar.

1 Like

I think @ACautionaryTale is proposing something slightly different: rather than booting from my existing clone, use recovery mode to create a fresh macOS install on an external disk and try to boot from that.


Searching on Google for ( error “-69670” ) turned up quite a few suggestions, most involving external drives. However it appears that forcing the drive to unmount may then allow you to reformat the drive.

I’ve never had this problem, but I’ve used diskutil to solve other problems from time to time. Since you can get into recovery mode this might be something to try. Good luck.

Well, sorry to hear all of this.

A new Apple display (if announced) attached to you M1 MBP might tide you over if the iMacs aren’t announced, or are not up to your needs.
Or if displays aren’t announced, perhaps an LG monitor.

For now, my temporary solution is to use my 14" MacBook Pro with a couple of external monitors (glad I bought that OWC Thunderbolt 3 Dock). Problem is, the camera I use for video calls is mounted on my iMac. Since my long-term plans are so unsettled I decided to just slide the carcass of my dead iMac back a little bit and put one of my external monitors in front of it.

The iMac is effectively serving as a very expensive camera stand. :sweat_smile:


As a rule, I only read the first 8 steps :wink: